Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

JSW:All hq-agent command fails on HP-UX

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.0.0, 4.3
  • Fix Version/s: None
  • Component/s: Agent / PDK
  • Environment:
    Server:Release 4.0.0-EE build 643,Platform:HP-UX

Description

Steps to Reproduce:

Install agent on HP-UX
go to bin folder
Run any hq-agent command

Actual Results:

bash-3.00$ sh hq-agent.sh start
chmod: can't access ../pdk/scripts/*
Unable to locate any of the following binaries:
/local0/hyperic/hyperic-hq-agent-4.0.0-EE/bin/../sbin/wrapper-hpux-9000/785-32
/local0/hyperic/hyperic-hq-agent-4.0.0-EE/bin/../sbin/wrapper-hpux-9000/785-64
/local0/hyperic/hyperic-hq-agent-4.0.0-EE/bin/../sbin/wrapper

Activity

Hide
Ryan Morgan added a comment -

Mark 4.0, assign to Gerardo

Show
Ryan Morgan added a comment - Mark 4.0, assign to Gerardo
Hide
Gerardo Viedma added a comment -

This issue seems to be caused when extracting the agent tar ball using the tar command. The presence of long file names in the tar ball result in a corrupted extraction of the files. Instead, the GNU gtar utility should be used to extract the agent on HPUX and Solaris platforms.

Show
Gerardo Viedma added a comment - This issue seems to be caused when extracting the agent tar ball using the tar command. The presence of long file names in the tar ball result in a corrupted extraction of the files. Instead, the GNU gtar utility should be used to extract the agent on HPUX and Solaris platforms.
Hide
Nipuna Bhayani added a comment -

Still problem in build 651
bash-3.00$ sh hq-agent.sh
Unable to locate any of the following binaries:
/local0/hyperic/hyperic-hq-agent-4.0.0-EE/sbin/wrapper-hpux-9000/785-32
/local0/hyperic/hyperic-hq-agent-4.0.0-EE/sbin/wrapper-hpux-9000/785-64
/local0/hyperic/hyperic-hq-agent-4.0.0-EE/sbin/wrapper

Show
Nipuna Bhayani added a comment - Still problem in build 651 bash-3.00$ sh hq-agent.sh Unable to locate any of the following binaries: /local0/hyperic/hyperic-hq-agent-4.0.0-EE/sbin/wrapper-hpux-9000/785-32 /local0/hyperic/hyperic-hq-agent-4.0.0-EE/sbin/wrapper-hpux-9000/785-64 /local0/hyperic/hyperic-hq-agent-4.0.0-EE/sbin/wrapper
Hide
Nipuna Bhayani added a comment -

As there is a workout so downgrading the priority to major.
Add executable permission for that sbin folder

Show
Nipuna Bhayani added a comment - As there is a workout so downgrading the priority to major. Add executable permission for that sbin folder
Hide
Nipuna Bhayani added a comment -

Fails again in release 4.1.0-EE build 995

-bash-3.00$ sh hq-agent.sh start
Unable to locate any of the following binaries:
/local0/hyperic/hyperic-hq-agent-4.1.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper-hpux-9000/785-32
/local0/hyperic/hyperic-hq-agent-4.1.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper-hpux-9000/785-64
/local0/hyperic/hyperic-hq-agent-4.1.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper

Show
Nipuna Bhayani added a comment - Fails again in release 4.1.0-EE build 995 -bash-3.00$ sh hq-agent.sh start Unable to locate any of the following binaries: /local0/hyperic/hyperic-hq-agent-4.1.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper-hpux-9000/785-32 /local0/hyperic/hyperic-hq-agent-4.1.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper-hpux-9000/785-64 /local0/hyperic/hyperic-hq-agent-4.1.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper
Hide
Todd Rader added a comment -

Chip, is this an installer issue? If not, please assign back and advise.

Show
Todd Rader added a comment - Chip, is this an installer issue? If not, please assign back and advise.
Hide
Chip Witt added a comment -

Seeing Nipuna's comment, assigning back to Todd untl we have lab time, and this issue is verified one way or the other.

Show
Chip Witt added a comment - Seeing Nipuna's comment, assigning back to Todd untl we have lab time, and this issue is verified one way or the other.
Hide
Frederic Calindas added a comment -

Reproduced with hq-agent 4.3.0-EE-1399 on HP-UX 11.11.

bash-2.04# ./hq-agent.sh start
Unable to locate any of the following binaries:
/local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper-hpux-9000/785-32
/local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper-hpux-9000/785-64
/local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper

As indicated, the fles do not exist. Looking at the directory shows:

bash-2.04# pwd
/local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin
bash-2.04# ls
wrapper-aix-ppc-32
wrapper-aix-ppc-64
wrapper-freebsd-x86-32
wrapper-hpux-parisc-32
wrapper-hpux-parisc-64
wrapper-linux-ppc-64
wrapper-linux-x86-32
wrapper-linux-x86-64
wrapper-macosx-ppc-32
wrapper-macosx-universal-32
wrapper-solaris-sparc-32
wrapper-solaris-sparc-64
wrapper-solaris-x86-32
wrapper-windows-x86-32.exe
bash-2.04#

Work around:
1. Within sbin sub-directory, create 'wrapper-hpux-9000' directory
2. CD to 'wrapper-hpux-9000' directory
3. Create softlink:

  • bash-2.04# ln -s /local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/wrapper-hpux-parisc-64 /local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/wrapper-hpux-9000/785-64
    4.Go to the bin directory and start hq-agent
Show
Frederic Calindas added a comment - Reproduced with hq-agent 4.3.0-EE-1399 on HP-UX 11.11. bash-2.04# ./hq-agent.sh start Unable to locate any of the following binaries: /local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper-hpux-9000/785-32 /local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper-hpux-9000/785-64 /local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/../../wrapper/sbin/wrapper As indicated, the fles do not exist. Looking at the directory shows: bash-2.04# pwd /local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin bash-2.04# ls wrapper-aix-ppc-32 wrapper-aix-ppc-64 wrapper-freebsd-x86-32 wrapper-hpux-parisc-32 wrapper-hpux-parisc-64 wrapper-linux-ppc-64 wrapper-linux-x86-32 wrapper-linux-x86-64 wrapper-macosx-ppc-32 wrapper-macosx-universal-32 wrapper-solaris-sparc-32 wrapper-solaris-sparc-64 wrapper-solaris-x86-32 wrapper-windows-x86-32.exe bash-2.04# Work around: 1. Within sbin sub-directory, create 'wrapper-hpux-9000' directory 2. CD to 'wrapper-hpux-9000' directory 3. Create softlink:
  • bash-2.04# ln -s /local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/wrapper-hpux-parisc-64 /local0/hq/hyperic-hq-agent-4.3.0-EE/wrapper/sbin/wrapper-hpux-9000/785-64 4.Go to the bin directory and start hq-agent
Hide
David Wiener added a comment -

Closed due to being outdated

Show
David Wiener added a comment - Closed due to being outdated

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 36 weeks, 6 days ago