Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

DataManagerEJBImpl throwing a "Hibernate Exception: Unable to find current session" every minute

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.2.0
  • Fix Version/s: None

Description

DataManagerEJBImpl throwing a "Hibernate Exception: Unable to find current session" every minute

Activity

Patrick Nguyen added a comment -

2009-05-14 12:37:58,159 DEBUG [pool-11-thread-9] [org.hyperic.hq.measurement.server.session.DataManagerEJBImpl] Attempting to insert data in a single transaction.
2009-05-14 12:37:58,160 DEBUG [pool-11-thread-9] [org.hyperic.hibernate.Util] Looking up SessionFactory JNDI = java:/HibernateSessionFactory
2009-05-14 12:37:58,160 DEBUG [pool-11-thread-9] [org.hyperic.hq.measurement.server.session.DataManagerEJBImpl] Attempting to insert 8 points
2009-05-14 12:37:58,160 DEBUG [pool-11-thread-9] [org.hyperic.hibernate.Util] Looking up SessionFactory JNDI = java:/HibernateSessionFactory
2009-05-14 12:37:58,164 DEBUG [pool-11-thread-9] [org.hyperic.hq.measurement.server.session.DataManagerEJBImpl] Need to deal with 0 unhandled data points (out of 8)
2009-05-14 12:37:58,164 DEBUG [pool-11-thread-9] [org.hyperic.hq.measurement.server.session.DataManagerEJBImpl] Num left = 0
2009-05-14 12:37:58,166 DEBUG [pool-11-thread-9] [org.hyperic.hq.measurement.server.session.DataManagerEJBImpl] Inserting data in a single transaction succeeded
2009-05-14 12:37:58,166 DEBUG [pool-11-thread-9] [org.hyperic.hq.measurement.server.session.DataManagerEJBImpl] Data Insertion process took 6 ms
2009-05-14 12:37:58,167 WARN [pool-11-thread-9] [org.hyperic.hq.measurement.ext.MeasurementEvent] Couldn't setup measurement event values.
org.hibernate.HibernateException: Unable to find current session
at org.hyperic.hq.hibernate.SessionManager.currentSession(SessionManager.java:180)
at org.hyperic.hq.hibernate.CurrentSessionFinder.currentSession(CurrentSessionFinder.java:42)
at org.hibernate.impl.SessionFactoryImpl.getCurrentSession(SessionFactoryImpl.java:544)
at org.hyperic.hq.dao.HibernateDAOFactory.getCurrentSession(HibernateDAOFactory.java:67)
at org.hyperic.hq.dao.HibernateDAO.getSession(HibernateDAO.java:64)
at org.hyperic.hq.dao.HibernateDAO.findById(HibernateDAO.java:84)
at org.hyperic.hq.dao.HibernateDAO.findById(HibernateDAO.java:76)
at org.hyperic.hq.measurement.server.session.MeasurementDAO.findById(MeasurementDAO.java:68)
at org.hyperic.hq.measurement.ext.MeasurementEvent.lazySetValues(MeasurementEvent.java:88)
at org.hyperic.hq.measurement.ext.MeasurementEvent.getUnits(MeasurementEvent.java:77)
at org.hyperic.hq.measurement.ext.MeasurementEvent.toString(MeasurementEvent.java:102)
at java.lang.String.valueOf(String.java:2615)
at java.util.AbstractCollection.toString(AbstractCollection.java:454)
at java.lang.String.valueOf(String.java:2615)
at java.lang.StringBuffer.append(StringBuffer.java:220)
at org.hyperic.hq.common.util.Messenger.publishMessage(Messenger.java:206)
at org.hyperic.hq.measurement.server.session.DataManagerEJBImpl.sendDataToEventHandlers(DataManagerEJBImpl.java:522)
at org.hyperic.hq.measurement.server.session.DataManagerEJBImpl.sendMetricEvents(DataManagerEJBImpl.java:479)
at org.hyperic.hq.measurement.server.session.DataManagerEJBImpl.addData(DataManagerEJBImpl.java:262)
at sun.reflect.GeneratedMethodAccessor1435.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.jboss.invocation.Invocation.performCall(Invocation.java:359)
at org.jboss.ejb.StatelessSessionContainer$ContainerInterceptor.invoke(StatelessSessionContainer.java:237)
at org.jboss.resource.connectionmanager.CachedConnectionInterceptor.invoke(CachedConnectionInterceptor.java:158)
at org.jboss.ejb.plugins.CallValidationInterceptor.invoke(CallValidationInterceptor.java:63)
at org.jboss.ejb.plugins.AbstractTxInterceptor.invokeNext(AbstractTxInterceptor.java:121)
at org.jboss.ejb.plugins.AbstractTxInterceptorBMT.invokeNext(AbstractTxInterceptorBMT.java:173)
at org.jboss.ejb.plugins.TxInterceptorBMT.invoke(TxInterceptorBMT.java:77)
at org.jboss.ejb.plugins.StatelessSessionInstanceInterceptor.invoke(StatelessSessionInstanceInterceptor.java:169)
at org.jboss.ejb.plugins.SecurityInterceptor.invoke(SecurityInterceptor.java:168)
at org.jboss.ejb.plugins.LogInterceptor.invoke(LogInterceptor.java:205)
at org.jboss.ejb.plugins.ProxyFactoryFinderInterceptor.invoke(ProxyFactoryFinderInterceptor.java:138)
at org.jboss.ejb.SessionContainer.internalInvoke(SessionContainer.java:648)
at org.jboss.ejb.Container.invoke(Container.java:960)
at org.jboss.ejb.plugins.local.BaseLocalProxyFactory.invoke(BaseLocalProxyFactory.java:430)
at org.jboss.ejb.plugins.local.StatelessSessionProxy.invoke(StatelessSessionProxy.java:103)
at $Proxy256.addData(Unknown Source)
at org.hyperic.hq.measurement.server.session.SynchronousDataInserter.insertMetrics(SynchronousDataInserter.java:44)
at com.hyperic.hq.measurement.server.session.BatchAggregateDataInserter$Worker.insertData(BatchAggregateDataInserter.java:477)
at com.hyperic.hq.measurement.server.session.BatchAggregateDataInserter$Worker.run(BatchAggregateDataInserter.java:506)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:280)
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:135)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:65)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:142)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:166)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
at java.lang.Thread.run(Thread.java:613)

David Wiener added a comment -

Closed due to being outdated


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 36 weeks, 4 days ago