Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Configuration options marked as type="secret" do not inherit default values

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.2.0
  • Fix Version/s: None
  • Component/s: None

Description

ConfigOptionTag does not handle setting the default value of a configuration property when it's marked as type="secret"

Normally, this is not an issue as it's assumed that if the type is secret the plugin won't know the value at time of auto-discovery. The problem is with custom plugins where the password is explicitly set in the plugin XML. There are currently 2 workarounds for this.

1) Use the <TypeName>.property=<value> trick in agent.properties
2) Modify the configuration option to not use the secret type. This has the downside of letting end users see the password, which is a non-starter.

Activity

David Wiener added a comment -

Closed due to being outdated


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 36 weeks, 2 days ago