Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

StaleStateException while deleting Alert Definitions

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.2.0
  • Fix Version/s: None
  • Component/s: Alerts

Description

while running the latest hqapi 3 test suite against my HQ Version 4.2.0-EE (build #1202 - Sep 03, 2009) server, the tests periodically bombs with the AlertDefinitionSync_test unit test while deleting alert definitions (probably some concurrency issues). a StaleStateException is thrown while executing AlertDefinitionManagerLocal.deleteAlertDefinitions(). i've attached a more detailed stack trace.

Testcase: testSyncActive took 0.44 sec
FAILED
An unexpected error occured expected:<SUCCESS> but was:<FAILURE>
junit.framework.AssertionFailedError: An unexpected error occured expected:<SUCCESS> but was:<FAILURE>
at org.hyperic.hq.hqapi1.test.HQApiTestBase.hqAssertSuccess(HQApiTestBase.java:183)
at org.hyperic.hq.hqapi1.test.AlertDefinitionTestBase.cleanup(AlertDefinitionTestBase.java:69)
at org.hyperic.hq.hqapi1.test.AlertDefinitionSync_test.testSyncActive(AlertDefinitionSync_test.java:314)

Activity

David Wiener added a comment -

Closed due to being outdated


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 36 weeks, 2 days ago