Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Stoping HQ-server via services on windows displays NPE error in server log

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.2.0
  • Fix Version/s: None
  • Component/s: Deprecated: Installer
  • Environment:
    Release 4.2.0-EE build 1208,Platform:Windowsxpsp2,DB:Built-in

Description

Steps to Reproduce

Install HQ-Server and HQ-agent as Windows Services
Start HQ-Server from Services
Stop HQ-server from services

Error in Server log

2009-09-10 09:49:22,984 INFO [JBoss Shutdown Hook] [org.jboss.resource.connectionmanager.ConnectionFactoryBindingService@169] Unbound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=HypericDS' from JNDI name 'java:HypericDS'
2009-09-10 09:49:22,984 INFO [JBoss Shutdown Hook] [org.quartz.core.QuartzScheduler@570] Scheduler DefaultQuartzScheduler_$_NON_CLUSTERED shutting down.
2009-09-10 09:49:22,984 INFO [JBoss Shutdown Hook] [org.quartz.core.QuartzScheduler@496] Scheduler DefaultQuartzScheduler_$_NON_CLUSTERED paused.
2009-09-10 09:49:22,984 INFO [JBoss Shutdown Hook] [org.quartz.core.QuartzScheduler@621] Scheduler DefaultQuartzScheduler_$_NON_CLUSTERED shutdown complete.
2009-09-10 09:49:23,000 INFO [JBoss Shutdown Hook] [org.jboss.mail.MailService@376] Mail service 'java:/Mail' removed from JNDI
2009-09-10 09:49:23,031 INFO [JBoss Shutdown Hook] [org.apache.coyote.http11.Http11Protocol@220] Pausing Coyote HTTP/1.1 on http-0.0.0.0-7080
2009-09-10 09:49:23,031 INFO [JBoss Shutdown Hook] [org.apache.coyote.ajp.AjpProtocol@204] Pausing Coyote AJP/1.3 on ajp-0.0.0.0-9009
2009-09-10 09:49:23,031 INFO [JBoss Shutdown Hook] [org.apache.coyote.http11.Http11Protocol@220] Pausing Coyote HTTP/1.1 on http-0.0.0.0-7443
2009-09-10 09:49:24,031 INFO [JBoss Shutdown Hook] [org.apache.catalina.core.StandardService@567] Stopping service jboss.web
2009-09-10 09:49:24,171 INFO [JBoss Shutdown Hook] [org.apache.coyote.http11.Http11Protocol@236] Stopping Coyote HTTP/1.1 on http-0.0.0.0-7080
2009-09-10 09:49:24,171 INFO [JBoss Shutdown Hook] [org.apache.coyote.ajp.AjpProtocol@220] Stopping Coyote AJP/1.3 on ajp-0.0.0.0-9009
2009-09-10 09:49:24,171 WARN [JBoss Shutdown Hook] [org.apache.catalina.connector.MapperListener@163] Error unregistering MBeanServerDelegate
java.lang.NullPointerException
at org.apache.catalina.connector.MapperListener.destroy(MapperListener.java:161)
at org.apache.catalina.connector.Connector.stop(Connector.java:1194)
at org.apache.catalina.core.StandardService.stop(StandardService.java:584)
at org.apache.catalina.core.StandardServer.stop(StandardServer.java:743)
at org.apache.catalina.startup.Catalina.stop(Catalina.java:626)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.tomcat.util.modeler.BaseModelMBean.invoke(BaseModelMBean.java:296)
at org.jboss.mx.server.RawDynamicInvoker.invoke(RawDynamicInvoker.java:164)
at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
at org.jboss.web.tomcat.service.JBossWeb.stopService(JBossWeb.java:549)
at org.jboss.system.ServiceMBeanSupport.jbossInternalStop(ServiceMBeanSupport.java:315)
at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMBeanSupport.java:247)
at sun.reflect.GeneratedMethodAccessor27.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133)
at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:142)
at org.jboss.mx.interceptor.DynamicInterceptor.invoke(DynamicInterceptor.java:97)
at org.jboss.deployment.SubDeployerInterceptor.invokeNext(SubDeployerInterceptor.java:124)
at org.jboss.deployment.SubDeployerInterceptor.invoke(SubDeployerInterceptor.java:109)
at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:978)
at $Proxy0.stop(Unknown Source)
at org.jboss.system.ServiceController.stop(ServiceController.java:508)
at org.jboss.system.ServiceController.stop(ServiceController.java:499)
at sun.reflect.GeneratedMethodAccessor1185.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
at $Proxy4.stop(Unknown Source)
at org.jboss.deployment.SARDeployer.stop(SARDeployer.java:338)
at org.jboss.deployment.MainDeployer.stop(MainDeployer.java:667)
at org.jboss.deployment.MainDeployer.undeploy(MainDeployer.java:638)
at org.jboss.deployment.MainDeployer.shutdown(MainDeployer.java:516)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133)
at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:142)
at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
at org.jboss.system.server.ServerImpl$ShutdownHook.shutdownDeployments(ServerImpl.java:1058)
at org.jboss.system.server.ServerImpl$ShutdownHook.shutdown(ServerImpl.java:1033)
at org.jboss.system.server.ServerImpl$ShutdownHook.run(ServerImpl.java:996)
2009-09-10 09:49:24,171 INFO [JBoss Shutdown Hook] [org.apache.coyote.http11.Http11Protocol@236] Stopping Coyote HTTP/1.1 on http-0.0.0.0-7443
2009-09-10 09:49:24,171 INFO [JBoss Shutdown Hook] [org.jboss.web.tomcat.service.TomcatDeployer@422] undeploy, ctxPath=/, warUrl=.../deploy/jboss-web.deployer/ROOT.war/
2009-09-10 09:49:24,171 INFO [JBoss Shutdown Hook] [org.jboss.web.tomcat.service.TomcatDeployer@422] undeploy, ctxPath=/jbossws, warUrl=.../deploy/jbossws.sar/jbossws-context.war/
2009-09-10 09:49:24,187 INFO [JBoss Shutdown Hook] [org.jboss.web.tomcat.service.TomcatDeployer@422] undeploy, ctxPath=/jboss-lather, warUrl=.../deploy/lather-jboss.sar/jboss-lather.war/
2009-09-10 09:49:24,312 INFO [JBoss Shutdown Hook] [com.arjuna.ats.jbossatx.jta.TransactionManagerService@300] Stopping recovery manager
2009-09-10 09:49:24,531 INFO [JBoss Shutdown Hook] [org.jboss.system.server.Server@1049] Shutdown complete

Activity

Todd Rader added a comment -

Looks suspiciously like a JBoss bug.

Todd Rader added a comment -

This bug will go away when we get off JBoss.

David Wiener added a comment -

Closed due to being outdated


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 37 weeks, 2 days ago