Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Exchange 2007 server is displaying "java.io.EOFException"

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.2.0, 4.5.1
  • Fix Version/s: None
  • Environment:
    Release 4.2.0-EE-1213,Platform:Linux,DB:MYSQL

Description

Steps to Reproduce

Install and start an agent on Exchange 2007
Add to Inventory
Go to Configuration page page
Click OK

Error in UI(Please see the attached Screen Shot)

Actual Results:

Exchange 2007 server is not collecting any availability ,but services under that are available

Agent log error(debug)

2009-09-29 09:43:12,544 DEBUG [Thread-0] [ScheduleThread] Created ResourceSchedule for: 3:10460
2009-09-29 09:43:12,544 DEBUG [Thread-0] [ScheduleThread] scheduleMeasurement exchange 2007 imap4:win32:service=msexchangeimap4:availability
2009-09-29 09:43:12,544 DEBUG [Thread-0] [ScheduleThread] scheduleMeasurement exchange 2007 imap4:win32:object=msexchangeimap4,instance=_total:current connections
2009-09-29 09:43:12,544 DEBUG [Thread-0] [ScheduleThread] scheduleMeasurement exchange 2007 imap4:win32:object=msexchangeimap4,instance=total:invalid commandsrate_=1m
2009-09-29 09:43:12,544 DEBUG [Thread-0] [ScheduleThread] scheduleMeasurement exchange 2007 imap4:win32:object=msexchangeimap4,instance=total:login totalrate_=1m
2009-09-29 09:43:12,544 DEBUG [Thread-0] [ScheduleThread] scheduleMeasurement exchange 2007 imap4:win32:object=msexchangeimap4,instance=total:status totalrate_=1m
2009-09-29 09:43:12,544 DEBUG [Thread-0] [MeasurementSchedule] Adding new SRN for entity 3:10460: Initial value = 4
2009-09-29 09:43:12,544 DEBUG [Thread-0] [CommandListener] Method 'org.hyperic.hq.agent.AgentCommand@848ecc' returned an object result
2009-09-29 09:43:12,544 DEBUG [Thread-0] [SSLConnectionListener] Handling SSL connection from /10.0.0.120
2009-09-29 09:43:12,654 DEBUG [Thread-1] [IisDetector] discovered 1 services
2009-09-29 09:43:12,654 INFO [Thread-1] [RuntimeAutodiscoverer] IIS 6.x discovery took 0.34
2009-09-29 09:43:12,654 INFO [Thread-1] [RuntimeAutodiscoverer] Running runtime autodiscovery for Exchange 2007
2009-09-29 09:43:12,763 DEBUG [Thread-0] [CommandListener] java.io.EOFException
java.io.EOFException
at java.io.DataInputStream.readInt(Unknown Source)
at org.hyperic.hq.agent.server.AgentServerConnection.readCommand(AgentServerConnection.java:76)
at org.hyperic.hq.agent.server.CommandListener.listenLoop(CommandListener.java:187)
at org.hyperic.hq.agent.server.AgentDaemon.start(AgentDaemon.java:844)
at org.hyperic.hq.agent.server.AgentDaemon$RunnableAgent.run(AgentDaemon.java:926)
at java.lang.Thread.run(Unknown Source)
2009-09-29 09:43:12,826 DEBUG [Thread-1] [ExchangeDetector] IMAP4 is running, adding to inventory
2009-09-29 09:43:12,826 DEBUG [Thread-1] [ExchangeDetector] POP3 is running, adding to inventory
2009-09-29 09:43:12,826 DEBUG [Thread-1] [ExchangeDetector] MTA is not running
2009-09-29 09:43:12,826 DEBUG [Thread-1] [ExchangeDetector] discovered 2 services
2009-09-29 09:43:12,826 INFO [Thread-1] [RuntimeAutodiscoverer] Exchange 2007 discovery took 0
2009-09-29 09:43:12,826 INFO [Thread-1] [RuntimeAutodiscoverer] Running runtime autodiscovery for HQ Agent
2009-09-29 09:43:12,982 DEBUG [Thread-1] [AgentServerDetector] no services discovered
2009-09-29 09:43:12,982 INFO [Thread-1] [RuntimeAutodiscoverer] HQ Agent discovery took 0
2009-09-29 09:43:12,982 INFO [Thread-1] [RuntimeAutodiscoverer] Running runtime autodiscovery for FileServer
2009-09-29 09:43:13,138 DEBUG [Thread-1] [SystemServerDetector] discovered exchange2007 Win32 File System C:\ (local/NTFS) [FileServer Mount]

  1. exchange_2007_command_metric.log
    20/Dec/10 12:37 PM
    32 kB
    Frederic Calindas
  2. exhange_2007_agent.log
    20/Dec/10 12:37 PM
    448 kB
    Frederic Calindas
  1. Exchange_2007_Invalid_Configuration.jpg
    59 kB
    20/Dec/10 12:37 PM
  2. screenshot-1.jpg
    120 kB
    29/Sep/09 10:25 AM
  3. screenshot-2.jpg
    227 kB
    29/Sep/09 10:27 AM

Activity

Doug MacEachern added a comment -

This sounds like a dup of: HHQ-2123

The EOFException is not related to Exchange, this has been reported before and I'm seeing it currently w/ vSphere.

2009-09-29 09:43:12,763 DEBUG [Thread-0] [CommandListener] java.io.EOFException
java.io.EOFException
at java.io.DataInputStream.readInt(Unknown Source)
at org.hyperic.hq.agent.server.AgentServerConnection.readCommand(AgentServerConnection.java:76)
at org.hyperic.hq.agent.server.CommandListener.listenLoop(CommandListener.java:187)
at org.hyperic.hq.agent.server.AgentDaemon.start(AgentDaemon.java:844)
at org.hyperic.hq.agent.server.AgentDaemon$RunnableAgent.run(AgentDaemon.java:926)
at java.lang.Thread.run(Unknown Source)

Kashyap Parikh added a comment -

Hi Frederic, Can you verify Exchange 2007 monitoring with 4.5 or 4.5.1.

Frederic Calindas added a comment -

Able to reproduce with 4.5.1-EE on originally reported environment.

See attached 'Exchange_2007_Invalid_Configuration.jpg' for reported UI message.

See attached 'exchange_2007_agent.log for agent logging.

See attached 'exchange_2007_command_metric.log' for command output.

David Wiener added a comment -

Closed due to being outdated


People

Vote (1)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 37 weeks, 3 days ago