Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Updating and Deleting Resource Type Alert Definitions are not Atomic Operations

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.2.0
  • Fix Version/s: None
  • Component/s: Alerts

Description

A database transaction failure (such as transaction timeouts) will cause the database transaction to rollback, but triggers that were removed from the in-memory repository up to the point of failure are removed "permanently". This issue is recoverable by restarting HQ since the in-memory repository will be re-created from the database. However, until HQ is restarted, the alert definitions whose triggers were removed from the in-memory repository will not fire if their conditions are satisfied.

RegisteredTriggerManagerEJBImpl.deleteAlertDefinitionTriggers() and RegisteredTriggerManagerEJBImpl .deleteTriggers() are the faulty code.

Activity

David Wiener added a comment -

Closed due to being outdated


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 36 weeks, 4 days ago