Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

After setting baselines from the Metric Data view by checking the checkbox and selecting Set Baselines does not seem to set them (at least in the UI)

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.2.0
  • Fix Version/s: None
  • Component/s: Deprecated: UI

Description

When trying to set baselines from the the Metric Data view, and then viewing the metric after, it says "Baseline: (not yet set)" next to it. So, it seems as though either it is really not set, or the UI is not updated.

From Metric Data View -> Select the check boxes next to your metrics you want to baseline -> Select Set Baselines button. Now select the Metric you just set the baselines on, when you scroll down to look at the baselines, it says "not yet set" next to the baseline values.

Attaching "Picture 8.png" to the ticket

Activity

Jason Konicki added a comment -

Picture 8.png

Kashyap Parikh added a comment -

I am not able to reproduce this in 4.2.0 RC. Here's what I did.

1. Find a metric that has collected measurements recently and that it doesn't have baselines calculated already (see before-clicking-SetBaseline.png)
2. Metric Data-> Click on the box next to metric-> Click Set baseline
3. Go to Single metric chart view for that metric and see that baselines appear for it (see after-clicking-SetBaseline.png)

Can you run following query on the measurement you are trying to calculate baseline for, just want to know if the metric has data and how many collections. Backend baseline engine requires atleast 40 data point and I am not sure if same requirement needs to be satisfied for use invokes baselines. It if does than that's a bug.

select * from eam_measurement m, eam_resource r, eam_measurement_data d
where r.instance_id=10004
and m.template_id=11319
and d.measurement_id=m.id
and r.id=m.resource_id;

Where r.instance_id = rid from url
m.template_id = m from url

URL i am referring to is from the link that shows up for the metric under Metric Data tab.
It looks like this -> http://localhost:7080/resource/common/monitor/Visibility.do?type=1&rid=10004&m=11319&mode=chartSingleMetricSingleResource

Jason Konicki added a comment -

Kashyap,

I think you are right about this. When I took the initial baseline, it was on a brand new install, and at that point it would not have data points. I have now tried with again on a different metric and it is no longer saying (not yet set) when I followed the save steps.

-Jason

David Wiener added a comment -

Closed due to being outdated


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 36 weeks, 6 days ago