Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

mysql _stats plugin doesn't reconnect after wait_timeout disconnect

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Deferred
  • Affects Version/s: 4.1.2, 4.2.0, 4.5
  • Fix Version/s: None
  • Component/s: Plugins
  • Case Links:
    none
  • Regression:
    No
  • Tags:

Description

To reproduce:

1. Configure mysql with wait_timeout under 60 seconds (note default global is 28800 seconds = 8hrs)
2. Configure agent to monitor mysql DB
3. After first couple of metric intervals agent stops collecting metric for mysql

2009-11-09 23:35:00,044 DEBUG [ScheduleThread] [JDBCQueryCache] re-populating JDBCQueryCache for SELECT * FROM information_schema.tables WHERE lower(table_name) = 'eam_numbers' AND lower(table_schema) = 'hqdb' AND engine is not null with queryKey of table_name
2009-11-09 23:35:00,044 DEBUG [ScheduleThread] [MySqlStatsMeasurementPlugin] com.mysql.jdbc.CommunicationsException: Communications link failure

The last packet successfully received from the server was 52,312 milliseconds ago. The last packet sent successfully to the server was 0 milliseconds ago.
com.mysql.jdbc.CommunicationsException: Communications link failure

The last packet successfully received from the server was 52,312 milliseconds ago. The last packet sent successfully to the server was 0 milliseconds ago.
at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:1070)
at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(MysqlIO.java:3052)
at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(MysqlIO.java:2938)
at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3481)
at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1959)
at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2109)
at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2642)
at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2571)
at com.mysql.jdbc.StatementImpl.executeQuery(StatementImpl.java:1464)
at org.hyperic.hq.product.JDBCQueryCache.repopulateCache(JDBCQueryCache.java:170)
at org.hyperic.hq.product.JDBCQueryCache.get(JDBCQueryCache.java:141)
at org.hyperic.hq.plugin.mysql_stats.MySqlStatsMeasurementPlugin.getTableMetric(MySqlStatsMeasurementPlugin.java:185)
at org.hyperic.hq.plugin.mysql_stats.MySqlStatsMeasurementPlugin.getQueryValue(MySqlStatsMeasurementPlugin.java:104)
at org.hyperic.hq.product.JDBCMeasurementPlugin.getValue(JDBCMeasurementPlugin.java:162)
at org.hyperic.hq.product.MeasurementPluginManager.getPluginValue(MeasurementPluginManager.java:176)
at org.hyperic.hq.product.MeasurementPluginManager.getValue(MeasurementPluginManager.java:274)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.getValue(ScheduleThread.java:298)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.collect(ScheduleThread.java:387)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.collect(ScheduleThread.java:344)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.collect(ScheduleThread.java:490)
at org.hyperic.hq.measurement.agent.server.ScheduleThread.run(ScheduleThread.java:512)
at java.lang.Thread.run(Unknown Source)
Caused by: java.io.EOFException: Can not read response from server. Expected to read 4 bytes, read 0 bytes before connection was unexpectedly lost.
at com.mysql.jdbc.MysqlIO.readFully(MysqlIO.java:2497)
at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(MysqlIO.java:2949)
... 20 more

Activity

Wes Schlichter added a comment -

Re-assigning to Mayan for re-prioritization.

Issue still exists in latest 4.5.2.2 mysql_stats plugin.

Idan Hod added a comment -

As part of our continuous effort to improve product quality, The Hyperic product team has decided to implement a "zero bug policy" methodology.

Following this methodology, only defects that are planned to be handled in the near future will remain open. Any other defect will be deferred, with the option to be reevaluated if the need arises, or if changes to the Hyperic road-map make such defect a candidate for a fix.

We believe this new process will help create clarity and focus in the Hyperic road-map and ultimately benefit our customer base.

This bug has been deferred as part of the new policy.

We appreciate your cooperation and continues contribution to the improvement of Hyperic.


People

Vote (1)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    41 weeks, 3 days ago