Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Sendmail plugin's ptql does not account for the sendmail client processes, this causes the availability metric to change when multiple processes that match the ptql are found.

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.2.0
  • Fix Version/s: None
  • Environment:
    linux with sendmail 8.13 installed

Description

This ticket came from the investigation of support issue: http://jira.hyperic.com/browse/SUPPORT-6347

Sendmail plugin's ptql does not account for the sendmail client processes, this causes the availability metric to change when multiple processes that match the ptql are found.

See the customers description for some background details.

It is recommended to add the following (or possibly an alternate version) to the top level availability process.query in the agent configuration and to the root process service config. <current ptql>,Args.-1.re=connections

Other possibilities (instead of the regular expression) could be: "ew=connections" or "ct=connections"

Activity

Jason Konicki added a comment -

I believe that after fixing HHQ-3554 this ticket is no longer necessary. The sendmail plugin does not need the addition of Args to the ptql.

David Wiener added a comment -

Closed due to being outdated


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 37 weeks, 2 days ago