Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

JVM parameters in hq-server.conf on windows are ignored

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Cannot Reproduce
  • Affects Version/s: 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.2.0
  • Fix Version/s: None
  • Environment:
    HQ on windows

Description

HQ installed on Windows uses registry values for HQ startup. JVM options specified in hq-server.conf (typically min/max heap and GC options) are ignored by server.

The work-around is to update/add registry values. To update min/max heap one need to update following registry values:

Update HKQY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Hyperic HQ Server\Parameters\OptionString.8 = -Xmx1024m
Add HKQY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Hyperic HQ Server\Parameters\OptionString.11 = -Xms1024m
Update HKQY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Hyperic HQ Server\Parameters\NumOptions = 12

Activity

David Wiener added a comment -

Closed due to being outdated


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 37 weeks, 3 days ago