Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

consistent slow method calls in AvailabilityManager.addData to HierarchicalAlertingManager.suppressMeasurementEvents

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Trivial Trivial
  • Resolution: Deferred
  • Affects Version/s: 4.3
  • Fix Version/s: None
  • Component/s: None
  • Case Links:
    none
  • Regression:
    No

Description

While working on a customer db with the multiAgent replayer I see consistent slow method calls to HierarchicalAlertingManager.suppressMeasurementEvents

2010-02-22 13:17:41,360 WARN [Timer-2] [org.hyperic.hq.application.HQApp@331] Method ran a long time.
Class: com.hyperic.hq.events.shared.HierarchicalAlertingManagerLocal
Method: suppressMeasurementEvents
RunTime: 66745

This could cause backups in the availability queue since this is part of the AvailabilityManager.addData() mechanism.

It could be related to memory issues from HHQ-3747, but not sure.

Issue Links

Activity

Idan Hod added a comment -

As part of our continuous effort to improve product quality, The Hyperic product team has decided to implement a "zero bug policy" methodology.

Following this methodology, only defects that are planned to be handled in the near future will remain open. Any other defect will be deferred, with the option to be reevaluated if the need arises, or if changes to the Hyperic road-map make such defect a candidate for a fix.

We believe this new process will help create clarity and focus in the Hyperic road-map and ultimately benefit our customer base.

This bug has been deferred as part of the new policy.

We appreciate your cooperation and continues contribution to the improvement of Hyperic.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    42 weeks ago