Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

A badly written plugin will prevent HQ from starting

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.5 M5
  • Fix Version/s: 4.6, 4.x Sprint 13
  • Component/s: None
  • Case Links:
    none
  • Regression:
    Yes
  • Tags:

Description

The plugin does have a known bug, but that fact should not prevent the server from starting

2010-06-07 11:05:41,067 ERROR [main] [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/]@3976] Exception sending context initialized event to listener instance of class org.hyperic.hq.context.BootstrapContextLoaderListener
org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'UIPluginDeployer' defined in file [/Users/benhale/Desktop/hyperic/server-4.5.0.BUILD-SNAPSHOT/hq-engine/hq-server/webapps/ROOT/WEB-INF/classes/org/hyperic/hq/ui/server/session/UIPluginDeployer.class]: Unsatisfied dependency expressed through constructor argument with index 1 of type [org.hyperic.hq.product.server.session.ProductPluginDeployer]: : Error creating bean with name 'productPluginDeployer': Invocation of init method failed; nested exception is java.lang.NoClassDefFoundError: com/springsource/hq/plugin/tcserver/serverconfig/resources/jdbc/DataSource; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'productPluginDeployer': Invocation of init method failed; nested exception is java.lang.NoClassDefFoundError: com/springsource/hq/plugin/tcserver/serverconfig/resources/jdbc/DataSource
	at org.springframework.beans.factory.support.ConstructorResolver.createArgumentArray(ConstructorResolver.java:698)
	at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:191)
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.autowireConstructor(AbstractAutowireCapableBeanFactory.java:984)
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:888)
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:479)
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:450)
	at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:290)
	at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
	at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:287)
	at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:189)
	at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:562)
	at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:871)
	at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:423)
	at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:272)
	at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:196)
	at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:47)
	at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3972)
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:4467)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:546)
	at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1038)
	at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:962)
	at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)
	at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1282)
	at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
	at org.apache.catalina.core.StandardHost.start(StandardHost.java:742)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
	at org.apache.catalina.core.StandardService.start(StandardService.java:516)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:596)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'productPluginDeployer': Invocation of init method failed; nested exception is java.lang.NoClassDefFoundError: com/springsource/hq/plugin/tcserver/serverconfig/resources/jdbc/DataSource
	at org.springframework.beans.factory.annotation.InitDestroyAnnotationBeanPostProcessor.postProcessBeforeInitialization(InitDestroyAnnotationBeanPostProcessor.java:133)
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyBeanPostProcessorsBeforeInitialization(AbstractAutowireCapableBeanFactory.java:394)
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1396)
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:513)
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:450)
	at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:290)
	at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
	at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:287)
	at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:189)
	at org.springframework.beans.factory.support.DefaultListableBeanFactory.findAutowireCandidates(DefaultListableBeanFactory.java:825)
	at org.springframework.beans.factory.support.DefaultListableBeanFactory.doResolveDependency(DefaultListableBeanFactory.java:767)
	at org.springframework.beans.factory.support.DefaultListableBeanFactory.resolveDependency(DefaultListableBeanFactory.java:685)
	at org.springframework.beans.factory.support.ConstructorResolver.resolveAutowiredArgument(ConstructorResolver.java:771)
	at org.springframework.beans.factory.support.ConstructorResolver.createArgumentArray(ConstructorResolver.java:691)
	... 39 more
Caused by: java.lang.NoClassDefFoundError: com/springsource/hq/plugin/tcserver/serverconfig/resources/jdbc/DataSource
	at com.springsource.hq.plugin.tcserver.plugin.serverconfig.resources.jdbc.DataSourcesConverter.<init>(DataSourcesConverter.java:27)
	at com.springsource.hq.plugin.tcserver.plugin.serverconfig.FileReadingSettingsFactory.<init>(FileReadingSettingsFactory.java:53)
	at com.springsource.hq.plugin.tcserver.plugin.serverconfig.DefaultServerConfigManager.<init>(DefaultServerConfigManager.java:17)
	at com.springsource.hq.plugin.tcserver.plugin.TomcatLiveDataPlugin.<init>(TomcatLiveDataPlugin.java:124)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
	at java.lang.Class.newInstance0(Class.java:355)
	at java.lang.Class.newInstance(Class.java:308)
	at org.hyperic.hq.product.ProductPlugin.getPlugin(ProductPlugin.java:265)
	at org.hyperic.hq.product.ProductPlugin.getPlugin(ProductPlugin.java:285)
	at org.hyperic.hq.product.ProductPluginManager.addPluginTypes(ProductPluginManager.java:1017)
	at org.hyperic.hq.product.ProductPluginManager.registerPluginJar(ProductPluginManager.java:984)
	at org.hyperic.hq.product.server.session.ProductPluginDeployer.registerPluginJar(ProductPluginDeployer.java:249)
	at org.hyperic.hq.product.server.session.ProductPluginDeployer.loadPlugin(ProductPluginDeployer.java:353)
	at org.hyperic.hq.product.server.session.ProductPluginDeployer.loadPlugins(ProductPluginDeployer.java:339)
	at org.hyperic.hq.product.server.session.ProductPluginDeployer.initializePlugins(ProductPluginDeployer.java:100)
	at org.hyperic.hq.product.server.session.ProductPluginDeployer.start(ProductPluginDeployer.java:280)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.springframework.beans.factory.annotation.InitDestroyAnnotationBeanPostProcessor$LifecycleElement.invoke(InitDestroyAnnotationBeanPostProcessor.java:340)
	at org.springframework.beans.factory.annotation.InitDestroyAnnotationBeanPostProcessor$LifecycleMetadata.invokeInitMethods(InitDestroyAnnotationBeanPostProcessor.java:293)
	at org.springframework.beans.factory.annotation.InitDestroyAnnotationBeanPostProcessor.postProcessBeforeInitialization(InitDestroyAnnotationBeanPostProcessor.java:130)
	... 52 more
Caused by: java.lang.ClassNotFoundException: com.springsource.hq.plugin.tcserver.serverconfig.resources.jdbc.DataSource
	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
	... 78 more
2010-06-07 11:05:41,070 ERROR [main] [org.apache.catalina.core.StandardContext@4468] Error listenerStart
2010-06-07 11:05:41,071 ERROR [main] [org.apache.catalina.core.StandardContext@4510] Context [] startup failed due to previous errors
2010-06-07 11:05:41,072 INFO  [main] [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/]@644] Closing Spring root WebApplicationContext
2010-06-07 11:05:41,075 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1778] A web application registered the JBDC driver [com.mysql.jdbc.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
2010-06-07 11:05:41,075 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1778] A web application registered the JBDC driver [oracle.jdbc.driver.OracleDriver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
2010-06-07 11:05:41,075 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1778] A web application registered the JBDC driver [org.postgresql.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
2010-06-07 11:05:41,076 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [MySQL Statement Cancellation Timer] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,076 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [Thread-3] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,076 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [pool-3-thread-1] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,076 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [EscalationRuntime] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,077 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [org.springframework.scheduling.quartz.SchedulerFactoryBean#0_Worker-1] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,077 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [org.springframework.scheduling.quartz.SchedulerFactoryBean#0_Worker-2] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,077 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [org.springframework.scheduling.quartz.SchedulerFactoryBean#0_Worker-3] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,077 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [org.springframework.scheduling.quartz.SchedulerFactoryBean#0_Worker-4] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,077 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [org.springframework.scheduling.quartz.SchedulerFactoryBean#0_Worker-5] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,104 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [Timer-0] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,104 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@1946] A web application appears to have started a thread named [ZeventProcessor] but has failed to stop it. This is very likely to create a memory leak.
2010-06-07 11:05:41,105 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Transactional resources]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,105 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Current aspect-driven transaction]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,106 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Transaction synchronizations]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,106 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Current transaction name]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,106 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Current transaction read-only status]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,106 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Current transaction isolation level]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,107 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Prototype beans currently in creation]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,107 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Hibernate Sessions registered for deferred close]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,108 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Actual transaction active]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,109 ERROR [main] [org.apache.catalina.loader.WebappClassLoader@2099] A web application created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Name of currently proxied bean]) and a value of type [null] (value [null]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
2010-06-07 11:05:41,818 INFO  [main] [org.apache.coyote.http11.Http11Protocol@209] Starting Coyote HTTP/1.1 on http-7080
2010-06-07 11:05:41,828 INFO  [main] [org.apache.coyote.http11.Http11Protocol@209] Starting Coyote HTTP/1.1 on http-7443
2010-06-07 11:05:41,866 INFO  [main] [org.apache.jk.common.ChannelSocket@388] JK: ajp13 listening on /0.0.0.0:9009
2010-06-07 11:05:41,872 INFO  [main] [org.apache.jk.server.JkMain@386] Jk running ID=0 time=0/18  config=null
2010-06-07 11:05:41,876 INFO  [main] [org.apache.catalina.startup.Catalina@604] Server startup in 22494 ms
2010-06-07 11:05:50,379 INFO  [pool-3-thread-1] [org.apache.catalina.loader.WebappClassLoader@1372] Illegal access: this web application instance has been stopped already.  Could not load org.hyperic.util.stats.StatsObject.  The eventual following stack trace is caused by an error thrown for debugging purposes as well as to attempt to terminate the thread which caused the illegal access, and has no functional impact.
java.lang.IllegalStateException
	at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1370)
	at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1329)
	at org.hyperic.hq.stats.ConcurrentStatsCollector$StatsWriter.getStatsByKey(ConcurrentStatsCollector.java:342)
	at org.hyperic.hq.stats.ConcurrentStatsCollector$StatsWriter.run(ConcurrentStatsCollector.java:283)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:181)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:205)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:637)

Activity

Kashyap Parikh added a comment -

Moving in 4.5

German Laullon added a comment -

I can't reproduce it.
If TCServer team see the problem again they can reopen the ticket and attach the "bad" plugin.

Yoav Epelman added a comment -

Nothing happened 2 years so i am closing it


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 6 weeks, 4 days ago