Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

java.lang.ClassCastException: when running autodiscoverer for plugin: OC4J 10

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Deferred
  • Affects Version/s: 4.2.0.8
  • Fix Version/s: None
  • Component/s: None
  • Environment:
    Windows 2003 32bit
    HQ 4.2.0.8
  • Case Links:
    none
  • Regression:
    No

Description

Seeing the following error message in agent.log when OC4J 10 driver is trying to autodiscover.

2010-07-30 12:36:59,421 ERROR [Thread-2] [RuntimeAutodiscoverer] Unexpected error running autodiscoverer for plugin: OC4J 10: [Ljava.lang.String; cannot be cast to java.util.Map
org.hyperic.hq.product.PluginException: [Ljava.lang.String; cannot be cast to java.util.Map
at org.hyperic.hq.product.jmx.MxServerDetector.discoverServices(MxServerDetector.java:473)
at org.hyperic.hq.product.ServerDetector.discoverResources(ServerDetector.java:221)
at org.hyperic.hq.autoinventory.agent.server.RuntimeAutodiscoverer.doRuntimeScan_internal(RuntimeAutodiscoverer.java:272)
at org.hyperic.hq.autoinventory.agent.server.RuntimeAutodiscoverer.doRuntimeScan(RuntimeAutodiscoverer.java:205)
at org.hyperic.hq.autoinventory.ScanManager.mainRunLoop(ScanManager.java:165)
at org.hyperic.hq.autoinventory.ScanManager.access$000(ScanManager.java:41)
at org.hyperic.hq.autoinventory.ScanManager$1.run(ScanManager.java:107)
Caused by: java.lang.ClassCastException: [Ljava.lang.String; cannot be cast to java.util.Map
at oracle.oc4j.admin.jmx.remote.rmi.RMIJMXConnectorImpl.getDomain(RMIJMXConnectorImpl.java:83)
at oracle.oc4j.admin.jmx.remote.JMXConnectorImpl.connect(JMXConnectorImpl.java:363)
at javax.management.remote.JMXConnectorFactory.connect(JMXConnectorFactory.java:248)
at org.hyperic.hq.product.jmx.MxUtil.getMBeanConnector(MxUtil.java:445)
at org.hyperic.hq.product.jmx.MxServerDetector.discoverServices(MxServerDetector.java:470)
... 6 more

Activity

Todd Rader added a comment -

Is this still reproducible?

German Laullon added a comment -

no in my env...
I think the newest agent JVM solve it.

Idan Hod added a comment -

As part of our continuous effort to improve product quality, The Hyperic product team has decided to implement a "zero bug policy" methodology.

Following this methodology, only defects that are planned to be handled in the near future will remain open. Any other defect will be deferred, with the option to be reevaluated if the need arises, or if changes to the Hyperic road-map make such defect a candidate for a fix.

We believe this new process will help create clarity and focus in the Hyperic road-map and ultimately benefit our customer base.

This bug has been deferred as part of the new policy.

We appreciate your cooperation and continues contribution to the improvement of Hyperic.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    41 weeks, 1 day ago