Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Re-registering the agent using hq-agent.sh setup between unidirectional and bi-directional can prevent the agent from registering

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Deferred
  • Affects Version/s: 4.2.0
  • Fix Version/s: None
  • Component/s: Agent / PDK
  • Case Links:
    none
  • Regression:
    No

Description

From SUPPORT-8552:

Re-registering the agent using hq-agent.sh setup between unidirectional and bi-directional can prevent the agent from registering.
After the steps below and the exception, the user will need to remove the table entries manually from the database.

Steps to Reproduce:

1.) Install bidirectional agent
2.) Stop that agent and delete it's data dir
3.) Now configure unidirectional agent for same platform
(at this point you should have one eam_agent entry for both)
4.) Don't delete data dir and leave agent running
5.) Run hq-agent.sh setup as bi-directional
6.) Stop agent and delete data dir
7.) Start agent and try to register with bidirectional again.

You will see something like this:
Starting HQ Agent...
[ Running agent setup ]
Should Agent communications to HQ be unidirectional [default=no]:
What is the HQ server IP address: 127.0.0.1
Should Agent communications to HQ always be secure [default=no]: yes
What is the HQ server SSL port [default=7443]: 7443

  • Testing secure connection ... Success
    What is your HQ login [default=hqadmin]: hqadmin
    What is your HQ password: *Not echoing value*
    What IP should HQ use to contact the agent [default=192.168.42.171]: 192.168.42.171
    What port should HQ use to contact the agent [default=2144]: 2144
  • Received temporary auth token from agent
  • Registering agent with HQ
    org.hyperic.hq.bizapp.client.AgentCallbackClientException: Remote error while invoking 'registerAgent: org.hyperic.lather.LatherRemoteException: Runtime exception: RuntimeException
    at org.hyperic.hq.bizapp.client.AgentCallbackClient.invokeLatherCall(AgentCallbackClient.java:201)
    at org.hyperic.hq.bizapp.client.BizappCallbackClient.registerAgent(BizappCallbackClient.java:135)
    at org.hyperic.hq.bizapp.agent.client.AgentClient.cmdSetup(AgentClient.java:808)
    at org.hyperic.hq.bizapp.agent.client.AgentClient.cmdSetupIfNoProvider(AgentClient.java:517)
    at org.hyperic.hq.bizapp.agent.client.AgentClient.main(AgentClient.java:1257)
    Caused by: org.hyperic.lather.LatherRemoteException: org.hyperic.lather.LatherRemoteException: Runtime exception: RuntimeException
    at org.hyperic.lather.client.LatherHTTPClient.invoke(LatherHTTPClient.java:124)
    at org.hyperic.hq.bizapp.client.AgentCallbackClient.invokeLatherCall(AgentCallbackClient.java:157)
    ... 4 more
  • Error registering agent: Remote error while invoking 'registerAgent: org.hyperic.lather.LatherRemoteException: Runtime exception: RuntimeException

Activity

Idan Hod added a comment -

As part of our continuous effort to improve product quality, The Hyperic product team has decided to implement a "zero bug policy" methodology.

Following this methodology, only defects that are planned to be handled in the near future will remain open. Any other defect will be deferred, with the option to be reevaluated if the need arises, or if changes to the Hyperic road-map make such defect a candidate for a fix.

We believe this new process will help create clarity and focus in the Hyperic road-map and ultimately benefit our customer base.

This bug has been deferred as part of the new policy.

We appreciate your cooperation and continues contribution to the improvement of Hyperic.


People

Vote (1)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    41 weeks ago