Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Command line plugin invocation throws NoClassDefFoundError

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Deferred
  • Affects Version/s: 4.4
  • Fix Version/s: None
  • Component/s: None

Description

~/hyperic/git/hq_ee/build/agent(4.4.0.x) $ java -jar bundles/agent-4.4.0.1-EE-1509/pdk/lib/hq-product.jar -m discover
Exception in thread "main" java.lang.NoClassDefFoundError: org/hyperic/hq/agent/server/AgentStorageProvider
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Class.java:2389)
at java.lang.Class.getConstructor0(Class.java:2699)
at java.lang.Class.newInstance0(Class.java:326)
at java.lang.Class.newInstance(Class.java:308)
at org.hyperic.hq.product.ProductPlugin.getPlugin(ProductPlugin.java:265)
at org.hyperic.hq.product.ProductPlugin.getPlugin(ProductPlugin.java:285)
at org.hyperic.hq.product.ProductPluginManager.addPluginTypes(ProductPluginManager.java:1099)
at org.hyperic.hq.product.ProductPluginManager.registerPluginJar(ProductPluginManager.java:1065)
at org.hyperic.hq.product.ProductPluginManager.registerPluginJar(ProductPluginManager.java:752)
at org.hyperic.hq.product.ProductPluginManager.registerPlugins(ProductPluginManager.java:844)
at org.hyperic.hq.product.util.PluginDumper.loadPlugins(PluginDumper.java:519)
at org.hyperic.hq.product.util.PluginDumper.init(PluginDumper.java:360)
at org.hyperic.hq.product.util.PluginMain.main(PluginMain.java:310)
Caused by: java.lang.ClassNotFoundException: org.hyperic.hq.agent.server.AgentStorageProvider
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
... 14 more

Issue Links

Activity

Ryan Morgan added a comment -

Regression from 4.3.

Frederic Calindas added a comment -

Appears to have broken in build 1475. No build 1474 to confirm. In build 1473 and below, the command line works.

Jason Konicki added a comment -

"java -jar pdk/lib/hq-product.jar -Dplugins.exclude=vsphere -m discover" will also work for the time being.

We can probably leave this out of the release since we have a workaround.

Jason Konicki added a comment -

Of course, we will not be able to debug the vsphere plugin, which was introduced in 4.4, so maybe this is still a issue we should fix.

Ryan Morgan added a comment -

Per CE triage move out of 4.4.0.1 since a) a workaround exists (-Dplugins.exclude=vsphere or copying of jar to pdk/lib) and b) it works as-is in 4.5.

I'm guessing we can just close this out.

Jennifer Hickey added a comment -

The only reason I would leave it open is if we want to enable testing of vsphere plugin auto-discovery from command line. The actual auto-discovery shouldn't be working in 4.5 since AgentStorageProvider is still not in classpath.

Jason Konicki added a comment -

To add to Ryan's comment, adding the AgentServer.jar from lib to pdk/lib makes this work. (as an ugly workaround).

Idan Hod added a comment -

As part of our continuous effort to improve product quality, The Hyperic product team has decided to implement a "zero bug policy" methodology.

Following this methodology, only defects that are planned to be handled in the near future will remain open. Any other defect will be deferred, with the option to be reevaluated if the need arises, or if changes to the Hyperic road-map make such defect a candidate for a fix.

We believe this new process will help create clarity and focus in the Hyperic road-map and ultimately benefit our customer base.

This bug has been deferred as part of the new policy.

We appreciate your cooperation and continues contribution to the improvement of Hyperic.


People

Vote (1)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    42 weeks, 1 day ago