Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

In HA setup all slave HQ nodes report all measurements not reporting in MetricsNotComingInDiagnostic report

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.4, 4.5
  • Fix Version/s: 4.5 Sprint 31, 4.5 M7, 4.5
  • Component/s: Deprecated: Server:HA
  • Environment:
    4.5 #85 with 2 node HA environment
  • Case Links:
    none
  • Regression:
    Yes
  • Story Points:
    3
  • Tags:

Description

MetricsNotComingInDiagnostic always report all measurements as not collecting on HA non-master nodes.
An example is below. Every metric listed below is actually reporting metrics fine.

2010-08-27 00:07:40,655 INFO [Thread-3] [org.hyperic.hq.common.DiagnosticsLogger@104] [org.hyperic.hq.measurement.MetricsNotComingInDiagnostic@17d6c0d]
Enabled metrics not reported in for 60 minutes (by platform hierarchy)
------------------------------------------------------------------------

fqdn=hatestserver2.intranet.hyperic.net (60 not collecting):
mid=10906, name=Peer Average Offset, resid=10935, resname=hatestserver2.intranet.hyperic.net NTP 4.x
mid=10907, name=Peers, resid=10935, resname=hatestserver2.intranet.hyperic.net NTP 4.x
mid=10467, name=Bits Received per Second, resid=10908, resname=hatestserver2.intranet.hyperic.net Linux Network Interface eth0 (ethernet)
mid=10469, name=Bits Transmitted per Second, resid=10908, resname=hatestserver2.intranet.hyperic.net Linux Network Interface eth0 (ethernet)
mid=10475, name=Packets Received per Minute, resid=10908, resname=hatestserver2.intranet.hyperic.net Linux Network Interface eth0 (ethernet)
mid=10477, name=Packets Transmitted per Minute, resid=10908, resname=hatestserver2.intranet.hyperic.net Linux Network Interface eth0 (ethernet)
mid=10439, name=Total Enqueue Count per Minute, resid=10906, resname=hatestserver2.intranet.hyperic.net HQ ActiveMQ Embedded 5.3 localhost Broker
mid=10441, name=Total Message Count per Minute, resid=10906, resname=hatestserver2.intranet.hyperic.net HQ ActiveMQ Embedded 5.3 localhost Broker
mid=10444, name=Bits Received per Second, resid=10907, resname=hatestserver2.intranet.hyperic.net Linux Network Interface lo (loopback)

Issue Links

Activity

Jennifer Hickey added a comment -

Kashyap, is this definitely a regression? Not seeing how this was guarded against in pre-4.5 code...

Patrick Nguyen added a comment -

it goes to the EhCacheMetricDataCache to determine whether metrics are not collecting for 60 minutes or more, so i can see why you are seeing this in the report on a non-master node. like jennifer mentioned, it looks like a pre-4.5 issue also. can you confirm?

Patrick Nguyen added a comment -

perhaps this report should be disabled or display nothing if it is on a non-master node.

Patrick Nguyen added a comment -

FIX 1: Only run the report if the HQ server is the master node in a HA configuration

Patrick Nguyen added a comment -

FIX 2: Reset the diagnostic start time if the server becomes the master node

Kashyap Parikh added a comment -

Slave nodes get this message in server.log

2010-10-22 14:38:08,082 INFO [Thread-2] [org.hyperic.hq.common.DiagnosticsLogger@104] [org.hyperic.hq.measurement.MetricsNotComingInDiagnostic@1e40bbe] Server must be the primary node in the HA configuration before this report is valid.


People

Vote (0)
Watch (2)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    3 years, 26 weeks, 5 days ago