Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Incorrect time displayed on resource charts with smaller time ranges

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.5, 4.6
  • Fix Version/s: 4.5.2.3, 4.6.0.2, 4.5.3, 4.6.5
  • Component/s: Deprecated: UI
  • Environment:
    MySQL, CentOS, 1342 platforms. build #92
  • Case Links:
    none
  • 3.0 Category:
    UI
  • Regression:
    Yes
  • Story Points:
    3
  • Tags:

Description

The singleChartMultiResource as well as singleChartSingleResource charts display incorrect time when time range selected is close to or lesser than an hour.

Steps:

1.Login to the portal
2.Go to resources -> platform
3.Select time range - 60 mins
4.Click on 'free memory' that creates a chart

result:
The time in the beginning of the chart is 12:25 pm (09/10), time at the end of the chart is 12:24 pm (09/10) and the time in between is correct.

5.Change the time range to 48 mins

result:
The same time is displayed throughout the chart

Attaching screenshots.

Marking as major because data is misleading but its specific to small time ranges and does not happen with larger (even 4 hour) time ranges.
Regression.. checked that it does not happen with 4.3

Issue Links

Activity

David Crutchfield added a comment -

The way the implementation currently works, if the interval is very you'll still see duplicates. They're correct however it doesn't look that way bc seconds aren't rendered on the charts.

David Crutchfield added a comment -

To clarify the previous comment, there was a fix implemented. However, if the time range contains data points that fall within the same minute, the x axis labels will show duplicates. This is bc the labels only display timestamps to the minute and don't show second information.

Dan Carwin added a comment -

Not fixed in 4.6 - seeing this behavior in 4.6

Dan Carwin added a comment -

Seeing this (or v.similar) in 4.6

Dan Carwin added a comment -

I asked to display a range from 3:50pm to 5:00pm

Wes Schlichter added a comment -

Re-assigning to Mayen to get some more visibility this is a must for 4.6.1

Wes Schlichter added a comment -

Found this to be caused by the same bug as HHQ-5244

Wes Schlichter added a comment -

See HHQ-5244 for details of regression

Wes Schlichter added a comment -

The fix for this that went into 4.6.0 didn't account for the continues in the for loop. It also needs the fixes from HHQ-5244 to be 100%.

Reverting the fixes in 4.6.0 and applying new fix

yael twina (c) added a comment -

checked on verssion 4.6.5.BUILD-SNAPSHOT-2011-12-28.
The problem did not appear in this version.


People

Vote (1)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 15 weeks, 5 days ago