Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

InetAddress Ping isn't thread safe in JRE shipped with agent

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.4
  • Fix Version/s: 4.6.5
  • Component/s: Agent / PDK
  • Case Links:
    none
  • Regression:
    No
  • Tags:

Description

The JRE we ship has a bug with InetAddress.isReachable() not being thread safe. Bug(among others) noted at http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6595834

Wes has verified that the latest update( 22) of java 1.6 doesn't contain this bug.

Steps to reproduce:

1.) Add InetAddress Ping service for host1
2.) Add InetAddress Ping service for host2

If one host goes down it may show as up since the icmp replies are not coded

Issue Links

Activity

Todd Rader added a comment -

1.6.0_20 is already approved by legal, and I sss 1.6.0_22 in the pipeline.

Wes Schlichter added a comment -

Jre upgraded in HHQ-5251


People

Vote (0)
Watch (2)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 18 weeks ago