Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Agent doesn't start "Critical error running agent java.lang.NoSuchFieldError: MINUTES"

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Blocker Blocker
  • Resolution: Fixed
  • Affects Version/s: 4.5.1
  • Fix Version/s: Sprint 36, 4.5.1, 4.6
  • Component/s: Agent / PDK
  • Environment:
    Release 4.5.1.BUILD-SNAPSHOT-2010-11-19 ,Platform:Linux ,DB:built-in
    Installer:hyperic-hqee-installer-4.5.1.BUILD-20101119.204308-2-x86-64-linux.tar.gz
  • Case Links:
    none
  • Regression:
    Yes

Description

Steps to Reproduce

untar the installer
go to agent/bin directory
[hyperic@vmc-ssrc-rh27 bin]$ sh hq-agent.sh start
Starting HQ Agent...
Error contacting agent: Unable to connect to 127.0.0.1:2146: Connection refused

Actual Results:

Agent log:

2010-11-19 19:01:21,952 ERROR [Thread-0] [AgentDaemon] Critical error running agent
java.lang.NoSuchFieldError: MINUTES
at org.hyperic.hq.measurement.agent.server.ScheduleThread.<init>(ScheduleThread.java:168)
at org.hyperic.hq.measurement.agent.server.MeasurementCommandsServer.startup(MeasurementCommandsServer.java:235)
at org.hyperic.hq.agent.server.AgentDaemon.startHandlers(AgentDaemon.java:712)
at org.hyperic.hq.agent.server.AgentDaemon.start(AgentDaemon.java:833)
at org.hyperic.hq.agent.server.AgentDaemon$RunnableAgent.run(AgentDaemon.java:930)
at java.lang.Thread.run(Unknown Source)
2010-11-19 19:01:21,953 DEBUG [Thread-0] [AgentDaemon] Notifying that agent startup failed
2010-11-19 19:01:21,953 DEBUG [Thread-0] [CommandsServer] handling notification: org.hyperic.hq.agent.server.AgentDaemon.agentFailedStart:agent startup failed!

  1. agent.log
    19/Nov/10 4:15 PM
    288 kB
    Nipuna Bhayani
  2. wrapper.log
    19/Nov/10 4:15 PM
    2 kB
    Nipuna Bhayani

Activity

Kashyap Parikh added a comment -

MINUTES was added in Java 6
http://java.sun.com/javase/6/docs/api/java/util/concurrent/TimeUnit.html#MINUTES

I can run agent with 1.6 JRE but since we need to support agent running 1.5 we need to fix it.

Ryan Morgan added a comment -

Changed to TimeUnit.SECONDS which is 1.5 compatible.

Ryan Morgan added a comment -


Jen, I think I fixed this after you did the merge to master. Can you re-sync the 4.5.1 branch to master please?

Jennifer Hickey added a comment -

Merged 4.5.x to master


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    3 years, 19 weeks, 6 days ago