Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Sybase plugin - NONE set for Collection Interval for Sybase Engine Service

Details

  • Type: Developer Developer
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.5.1
  • Fix Version/s: 4.5.3, 4.6.5
  • Environment:
    HQ-server 4.5.1-EE-27 running on CentOS 5.4 x64
    HQ-agent 4.5.1-EE-27 running on RHEL 5.5 x64
     - Sybase 15.5 ASE running with HQ-agent
  • Case Links:
    none
  • Regression:
    No

Description

Sybase plugin - NONE set for Collection Interval for Sybase Engine Service.

For the Sybase Engine service, the configuration properties are automatically populated with the correct values but initially shows as an invalid configuration. Going to the Sybase engine service shows:

This resource is turned off or has not been configured properly.
The problem is: Invalid configuration: Error retrieving value: EngineUtilization
Please turn on the server, or fix its Configuration Properties.

Clicking on the Ok button within the Configuration Properties reports:

The configuration has not been set for this resource due to : Invalid configuration: Error retrieving value: EngineUtilization

Clicking a second time, the changes will actually be saved (even though no modifications to configuration was made).

Now looking at the Metric Data for the Sybase Engine service shows ALL metrics with Collection Interval set to NONE.

Expected Result:
Monitoring Default values should be assigned to Collection Intervals for Sybase Engine Service metrics.

Actual Result:
NONE is set for Collection Interval for all Sybase Engine Service metrics.

Steps to Reproduce:
1. Install and start agent on platform running Sybase ASE 15.5
2. Log into Hyperic
3. Add Sybase platform to inventory from auto-discovery
4. Configure Sybase server
5. Ensure all services are set for collection
6. Allow metrics to collect
7. Examine Sybase Engine service
8. Note service indicates Invalid Configuration
9. Click OK button in configuration properties until changes are saved
10. Examine metrics for Sybase Engine service
11. Note all metrics have Collection Intervals set to NONE

Issue Links

Activity

Frederic Calindas added a comment -

This Issue could be related to the Invalid Configuration issue as a two-part problem to the same issue.

Ryan Morgan added a comment -


Mark 4.5.3 per triage, also adding 4.6.1 as this fix will be also committed to 4.6.x. If 4.6.5 is released in favor of 4.6.1 we'll move all bugs in 4.6.1 over to that fix version.

German Laullon added a comment -

I've merge the changes to Master and cherry pick it to 4.5.x.

Mayan Weiss added a comment -

this bug was reopened since it was mistakenly closed instead of resolved

moving it but to the resolved status it should be in

thanks


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 15 weeks, 2 days ago