Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

When a server resource is restarted, don't restart the file watcher

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Deferred
  • Affects Version/s: 4.5
  • Fix Version/s: None
  • Component/s: Agent / PDK
  • Case Links:
    none
  • Regression:
    No

Description

While enabling config tracking for tc Server, I discovered that when tc Server is restarted, the file watcher is also restarted. After some time testing config tracking, I came to realize that because the file watcher was restarting it was causing inconsistencies in reporting changes to the config file (conf/server.xml). If I only made changes to the config file and did not restart tc Server, the file watcher reported the changes much more consistently.

Upon speaking with Jennifer about this behavior, she suggested I create a new issue to indicate that the fiie watcher should not be restarted just because the server resource is restarted.

Activity

Idan Hod added a comment -

As part of our continuous effort to improve product quality, The Hyperic product team has decided to implement a "zero bug policy" methodology.

Following this methodology, only defects that are planned to be handled in the near future will remain open. Any other defect will be deferred, with the option to be reevaluated if the need arises, or if changes to the Hyperic road-map make such defect a candidate for a fix.

We believe this new process will help create clarity and focus in the Hyperic road-map and ultimately benefit our customer base.

This bug has been deferred as part of the new policy.

We appreciate your cooperation and continues contribution to the improvement of Hyperic.


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    41 weeks, 2 days ago