Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Cannot start agent on zlinux; unable to locate binaries

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Deferred
  • Affects Version/s: 4.5, 4.5.1
  • Fix Version/s: None
  • Component/s: Agent / PDK
  • Environment:
    HQ-server 4.5.0-EE-GA running on RHEL 5.4
    HQ-agent 4.5.0-EE-GA running on zlinux RHEL 5.2
  • Case Links:
    none
  • Regression:
    No

Description

Cannot start agent on zlinux; unable to locate binaries.

When installing the nojre agent on zlinux, starting the agent fails and reports:

$ ./hq-agent.sh start
Unable to locate any of the following binaries:
/opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/../../wrapper/sbin/wrapper-linux-s390x-32
/opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/../../wrapper/sbin/wrapper-linux-s390x-64
/opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/../../wrapper/sbin/wrapper

The binaries could not be located as they really do no exist.

The variable HQ_JAVA_HOME is set to use:

$ $HQ_JAVA_HOME/bin/java -version
java version "1.6.0"
Java(TM) SE Runtime Environment (build pxz6460sr1-20080419_01(SR1))
IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 Linux s390x-64 jvmxz6460-20080416_18762 (JIT enabled, AOT enabled)
J9VM - 20080415_018762_BHdSMr
JIT - r9_20080415_1520
GC - 20080415_AA)
JCL - 20080412_01

The platform details are:

$ uname -a
Linux xxxxxxx.dfw.ibm.com 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:58 EDT 2008 s390x s390x s390x GNU/Linux

Expected Result:
Able to install and successfully start an agent on supported platforms.

Actual Result:
Not able to successfully start an agent on zlunix.

Steps to Reproduce:
1. Install Hyperic agent on zlinux.
2. Export HQ_JAVA_HOME to use existing java.
3. Start agent.
4. Note the agent fails to start and reported message received.

Additional Information:
Same results received with 4.5.1 agent.

According to the Java Service Wrapper 3.5.0 release notes, support for zLinux 32 and 64-bit on s390 and s390x systems was added.

Activity

Kashyap Parikh added a comment -

Workaround is to run no-wrapper agent until we upgrade java-service-wrapper to 3.5

Frederic Calindas added a comment -

Attempted to updated the JSW to version 3.5.6; however, was no available community build; zlinux support only added in standard or professional editions which require a license but was able to obtain a temporary license.

Trying to start hq-agent caused a dump. The wrapper.log reported:

STATUS | wrapper | 2010/12/16 13:22:40 | --> Wrapper Started as Daemon
STATUS | wrapper | 2010/12/16 13:22:40 | Java Service Wrapper Professional Edition 64-bit 3.5.6
STATUS | wrapper | 2010/12/16 13:22:40 | Copyright (C) 1999-2010 Tanuki Software, Ltd. All Rights Reserved.
STATUS | wrapper | 2010/12/16 13:22:40 | http://wrapper.tanukisoftware.com
STATUS | wrapper | 2010/12/16 13:22:40 | Licensed to Hyperic
NOTICE | wrapper | 2010/12/16 13:22:40 |
NOTICE | wrapper | 2010/12/16 13:22:40 | --------------------------------------------------------------------
NOTICE | wrapper | 2010/12/16 13:22:40 | Thank you for your interest in the Java Service Wrapper.
NOTICE | wrapper | 2010/12/16 13:22:40 |
NOTICE | wrapper | 2010/12/16 13:22:40 | You are running with a full featured trial License Key which will
NOTICE | wrapper | 2010/12/16 13:22:40 | allow you to run or restart the Java Service Wrapper as many times
NOTICE | wrapper | 2010/12/16 13:22:40 | as you like until 2011/01/17. If the Wrapper is running at that
NOTICE | wrapper | 2010/12/16 13:22:40 | point, it will shutdown on its own after an additional 24 hours.
NOTICE | wrapper | 2010/12/16 13:22:40 |
NOTICE | wrapper | 2010/12/16 13:22:40 | The Java Service Wrapper requires a License Key to activate the
NOTICE | wrapper | 2010/12/16 13:22:40 | software. License Keys can be purchased on the Java Service Wrapper
NOTICE | wrapper | 2010/12/16 13:22:40 | web site:
NOTICE | wrapper | 2010/12/16 13:22:40 | http://wrapper.tanukisoftware.com/purchase
NOTICE | wrapper | 2010/12/16 13:22:40 |
NOTICE | wrapper | 2010/12/16 13:22:40 | This trial License Key in intended for testing and development and
NOTICE | wrapper | 2010/12/16 13:22:40 | should not be used as part of a production environment.
NOTICE | wrapper | 2010/12/16 13:22:40 | --------------------------------------------------------------------
NOTICE | wrapper | 2010/12/16 13:22:40 |
STATUS | wrapper | 2010/12/16 13:22:40 |
STATUS | wrapper | 2010/12/16 13:22:40 | Launching a JVM...
INFO | jvm 1 | 2010/12/16 13:22:41 | WrapperManager: Initializing...
INFO | jvm 1 | 2010/12/16 13:22:44 | Unhandled exception
INFO | jvm 1 | 2010/12/16 13:22:44 | Type=Segmentation error vmState=0x00000000
INFO | jvm 1 | 2010/12/16 13:22:44 | J9Generic_Signal_Number=00000004 Signal_Number=0000000b Error_Value=14f5fe60 Signal_Code=00000001
INFO | jvm 1 | 2010/12/16 13:22:44 | Handler1=0000020000A6AB18 Handler2=0000020000AFFB6C InaccessibleAddress=0000000000000000
INFO | jvm 1 | 2010/12/16 13:22:44 | gpr0=0000000000000000 gpr1=0000000000000000 gpr2=0000020000A235B8 gpr3=0000020000000000
INFO | jvm 1 | 2010/12/16 13:22:44 | gpr4=00000000800A502E gpr5=00000000000000F2 gpr6=0000020000A23920 gpr7=00000000800A502E
INFO | jvm 1 | 2010/12/16 13:22:44 | gpr8=0000000000000000 gpr9=0000020000A235C0 gpr10=00000000000000F2 gpr11=0000020000A23780
INFO | jvm 1 | 2010/12/16 13:22:44 | gpr12=000000008009AEB0 gpr13=0000020000B0F668 gpr14=0000020000A23478 gpr15=0000020000A233B0
INFO | jvm 1 | 2010/12/16 13:22:44 | psw=0000020000B05838 mask=0705E00180000000 fpc=0008000000000000
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr0 4140000000000000 (f: 0.000000, d: 2.097152e+06)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr1 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr2 3f800000574ca660 (f: 1464641152.000000, d: 7.812503e-03)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr3 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr4 3ff3333333333333 (f: 858993472.000000, d: 1.200000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr5 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr6 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr7 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr8 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr9 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr10 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr11 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr12 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr13 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr14 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | fpr15 0000000000000000 (f: 0.000000, d: 0.000000e+00)
INFO | jvm 1 | 2010/12/16 13:22:44 | Module=/opt/ibm/java-s390x-60/jre/lib/s390x/default/libj9prt24.so
INFO | jvm 1 | 2010/12/16 13:22:44 | Module_base_address=0000020000AEA000
INFO | jvm 1 | 2010/12/16 13:22:44 | Target=2_40_20080415_018762_BHdSMr (Linux 2.6.18-92.el5)
INFO | jvm 1 | 2010/12/16 13:22:44 | CPU=s390x (1 logical CPUs) (0x1f34b000 RAM)
INFO | jvm 1 | 2010/12/16 13:22:44 | ----------- Stack Backtrace -----------
INFO | jvm 1 | 2010/12/16 13:22:44 | /opt/ibm/java-s390x-60/jre/lib/s390x/default/libj9prt24.so [0x20000af69b4]
INFO | jvm 1 | 2010/12/16 13:22:44 | ---------------------------------------
INFO | jvm 1 | 2010/12/16 13:22:44 | JVMDUMP006I Processing dump event "gpf", detail "" - please wait.
INFO | jvm 1 | 2010/12/16 13:22:44 | JVMDUMP007I JVM Requesting System dump using '/opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/core.20101216.132244.9092.0001.dmp'
INFO | jvm 1 | 2010/12/16 13:22:44 | JVMDUMP010I System dump written to /opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/core.20101216.132244.9092.0001.dmp
INFO | jvm 1 | 2010/12/16 13:22:44 | JVMDUMP007I JVM Requesting Snap dump using '/opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/Snap.20101216.132244.9092.0002.trc'
INFO | jvm 1 | 2010/12/16 13:22:44 | JVMDUMP010I Snap dump written to /opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/Snap.20101216.132244.9092.0002.trc
INFO | jvm 1 | 2010/12/16 13:22:44 | JVMDUMP007I JVM Requesting Java dump using '/opt/hyperic/4.5-EE-GA/hyperic-hqee-agent-4.5/wrapper/sbin/javacore.20101216.132244.9092.0003.txt'
ERROR | wrapper | 2010/12/16 13:23:12 | Startup failed: Timed out waiting for a signal from the JVM.
ERROR | wrapper | 2010/12/16 13:23:13 | JVM did not exit on request, terminated
STATUS | wrapper | 2010/12/16 13:23:13 | JVM received a signal SIGKILL (9).

See attached files for additional information.

Frederic Calindas added a comment -

The dmp file is larger than 10 MB.

Idan Hod added a comment -

As part of our continuous effort to improve product quality, The Hyperic product team has decided to implement a "zero bug policy" methodology.

Following this methodology, only defects that are planned to be handled in the near future will remain open. Any other defect will be deferred, with the option to be reevaluated if the need arises, or if changes to the Hyperic road-map make such defect a candidate for a fix.

We believe this new process will help create clarity and focus in the Hyperic road-map and ultimately benefit our customer base.

This bug has been deferred as part of the new policy.

We appreciate your cooperation and continues contribution to the improvement of Hyperic.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    42 weeks ago