Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Stacktrace generating breadcrumbs for deleted resources

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.5
  • Fix Version/s: 4.5.1.2
  • Component/s: Deprecated: UI
  • Case Links:
    none
  • Regression:
    No
  • Story Points:
    3
  • Tags:

Description

Still working on a reproduction, but ResourceBreadcrumbTag.isParentOfAutoGroup() can throw an NPE leading to a stacktrace when viewing resources.

The specific error is:

javax.servlet.jsp.JspException: java.lang.NullPointerException at org.hyperic.hq.ui.taglib.ResourceBreadcrumbTag.doStartTag(ResourceBreadcrumbTag.java:104)
...
Caused by:
java.lang.NullPointerException at org.hyperic.hq.ui.taglib.ResourceBreadcrumbTag.isParentOfAutoGroup(ResourceBreadcrumbTag.java:364)

That part of the code is:

ResourceManagerLocal resourceManager = ResourceManagerEJBImpl.getOne();
Resource parentResource = resourceManager.findResource(parent.getAppdefEntityId());
Resource parentOfAutoGroupResource = resourceManager.findResource(new AppdefEntityID(group.getResourceId()));

result = parentResource.equals(parentOfAutoGroupResource);

Parent resource is not null, but the call to resourceManager.findResource(parent.getAppdefEntityId()) returns null leading to an NPE when checking equality.

Activity

Ryan Morgan added a comment -

Moving issues to 4.5.1.2.

Frederic Calindas added a comment -

Unable to reproduce issue to generate breadcrumbs for deleted resources; unable to get environment into pre-conditioned state.

Fix involved avoiding null pointer exception.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    3 years, 13 weeks, 1 day ago