Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

hq-agent-nowrapper.bat script does not work in 4.5

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Fixed
  • Affects Version/s: 4.5
  • Fix Version/s: 4.5.1.2
  • Component/s: Agent / PDK
  • Case Links:
    none
  • Regression:
    Yes
  • Tags:

Description

hq-agent-nowrapper.bat script does not work in 4.5.

I tried to start the agent with using the script and it has several problems.

1) The main class is not found.
2) After fixing 1) manually, it now can't find the properties for agent.bundle.home.
3) After fixing 2) manually, it still had incorrect paths.

Activity

Frederic Calindas added a comment -

Verified with 4.5.1.2-EE-19 on Windows 7 Enterprise x64.

With 4.5.1.2-EE-13 build (before fix), set HQ_JAVA_HOME and tried running hq-agent-nowrapper.bat:

C:\HQ\4.5.1.2-EE-13\agent-4.5.1.2.BUILD-SNAPSHOT-EE\bundles\agent-4.5.1.2.BUILD-SNAPSHOT\bin>set HQ_JAVA_HOME=C:\jre6_U20_64

C:\HQ\4.5.1.2-EE-13\agent-4.5.1.2.BUILD-SNAPSHOT-EE\bundles\agent-4.5.1.2.BUILD-SNAPSHOT\bin>%HQ_JAVA_HOME%\bin\java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)

C:\HQ\4.5.1.2-EE-13\agent-4.5.1.2.BUILD-SNAPSHOT-EE\bundles\agent-4.5.1.2.BUILD-SNAPSHOT\bin>hq-agent-nowrapper.bat start
Starting agent
Exception in thread "main" java.lang.NoClassDefFoundError: org/hyperic/hq/bizapp/agent/client/AgentClient
Caused by: java.lang.ClassNotFoundException: org.hyperic.hq.bizapp.agent.client.AgentClient
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
Could not find the main class: org.hyperic.hq.bizapp.agent.client.AgentClient. Program will exit.

After installing 4.5.1.2-EE-19 build (post fix), ran hq-agent-nowrapper.bat:

C:\HQ\4.5.1.2-EE-19\hyperic-hqee-agent-4.5.1.2.BUILD-SNAPSHOT\bundles\agent-4.5.1.2.BUILD-SNAPSHOT\bin>hq-agent-nowrapper.bat start
Starting agent

  • Unable to load agent token file. Generating a new one ... Done
  • Invoking agent
  • Agent thread running
  • Verifying if agent is running...
  • Agent is running
    Agent successfully started

[ Running agent setup ]
Should Agent communications to HQ be unidirectional [default=no]:
What is the HQ server IP address: xxx.xxx.xxx.xxx
Should Agent communications to HQ always be secure [default=no]:
What is the HQ server port [default=7080]:

  • Testing insecure connection ... Success

The platform was successfully auto-discovered by server.
What is your HQ login [default=hqadmin]:
What is your HQ password:
What IP should HQ use to contact the agent [default=xxx.xxx.xxx.xxx]:
What port should HQ use to contact the agent [default=2144]:

  • Received temporary auth token from agent
  • Registering agent with HQ
  • HQ gave us the following agent token
    1295898562593-7787982058071873165-8911120957979959005
  • Informing agent of new HQ server
  • Validating
  • Successfully setup agent
  • Unable to load agent token file. Generating a new one ... Done
  • Invoking agent
  • Agent thread running
  • Verifying if agent is running...
  • Agent is running Agent successfully started
[ Running agent setup ] Should Agent communications to HQ be unidirectional [default=no]: What is the HQ server IP address: xxx.xxx.xxx.xxx Should Agent communications to HQ always be secure [default=no]: What is the HQ server port [default=7080]:
  • Testing insecure connection ... Success
The platform was successfully auto-discovered by server. What is your HQ login [default=hqadmin]: What is your HQ password: What IP should HQ use to contact the agent [default=xxx.xxx.xxx.xxx]: What port should HQ use to contact the agent [default=2144]:
  • Received temporary auth token from agent
  • Registering agent with HQ
  • HQ gave us the following agent token 1295898562593-7787982058071873165-8911120957979959005
  • Informing agent of new HQ server
  • Validating
  • Successfully setup agent

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    3 years, 12 weeks, 4 days ago