Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Zip and MSI installer on 64 bit windows 7 fails with default install path [c:\Program Files (x86)]

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Invalid
  • Affects Version/s: 4.5.1
  • Fix Version/s: None
  • Environment:
    Zip and MSI installer on Windows 7 (64 bit)
  • Importance:
    4-Low
  • Case Links:
    none
  • Regression:
    Yes
  • Tags:

Description

Zip and MSI installer on 64 bit Windows 7 fails with default install path (c:\Program Files (x86)). Same installer works fine on Windows 2003 and Windows 2008 when install path is c:\Program Files (x86). From the error it looks like it silently failed to create Windows Service (since I don't see any Hyperic Server Service) and when it tried to start the service it failed. See attached screenshot for error message. Hyperic install log has no errors.

Activity

Frederic Calindas added a comment -

Tested 4.5.1-EE zip installer on Windows 7 x64 with the following findings:

  1. CANNOT install to "Program Files (x86)"

The following is reported when trying to install service:

C:\Program Files (x86)\Hyperic\4.5.1-EE\server-4.5.1-EE\bin>hq-server.bat install
\Hyperic\4.5.1-EE\server-4.5.1-EE\bin\..\jre was unexpected at this time.

  1. CAN install in "Program Files"

Additional Information:
MSI installer fails for both installations on Windows 7 x64 to "Program Files (x86)" and Program Files" directories

On Windows 2008 x64:

  1. CAN install in "Program Files (x86)" using zip installer
  1. CANNOT install to "Program Files (x86)"
The following is reported when trying to install service: C:\Program Files (x86)\Hyperic\4.5.1-EE\server-4.5.1-EE\bin>hq-server.bat install \Hyperic\4.5.1-EE\server-4.5.1-EE\bin\..\jre was unexpected at this time.
  1. CAN install in "Program Files"
Additional Information: MSI installer fails for both installations on Windows 7 x64 to "Program Files (x86)" and Program Files" directories On Windows 2008 x64:
  1. CAN install in "Program Files (x86)" using zip installer
Todd Rader added a comment -

User input:

Same installer works fine on Windows 2003 and Windows 2008 when install path is c:\Program Files (x86)

It actually exhibits the same behavior described for W7-64 in the bug, e.g. it fails the same way on my copy of Windows 2008 R2 Enterprise (64 bit).

The reason I am sending this note is two fold:

1. I was curious if there is a work around to this to get the product running on W2K8 R2 64 bit.
2. I just wanted to mention that from 10,000 feet, it looks similar to other Tomcat 64 bit service wrapper issues described in the following two posts.

http://stackoverflow.com/questions/211446/how-to-run-tomcat-6-on-winxp-64-bit
http://blog.bigrocksoftware.com/2010/10/07/commons-daemon-procrun-as-a-java-service-wrapper-for-activemq/

Todd Rader added a comment -

Need to re-test after wrapper upgrade


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    3 years, 14 weeks, 3 days ago