Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Upgrade our shipped ojdbc jar to ojdbc6.jar

Details

  • Type: Improvement Improvement
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: None
  • Fix Version/s: 4.6, 4.x Sprint 14
  • Component/s: None
  • Case Links:
    none
  • Regression:
    No
  • Tags:

Description

We should upgrade our shipped oracle jdbc jar from the current ojdbc14.jar to ojdbc6.jar.

We only support Oracle 10 and 11 database and JDK 1.5 and 1.6. So we should move to the latest ojdbc.jar that is supported by both JDKs.
And according to the oracle FAQ ojdbc6.jar is it. http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-faq-090281.html#02_03

This ticket should have subtasks that include the update of the oracle plugin and any needed documentation change.

Activity

Hide
Todd Rader added a comment -

Server, agent, or both?

Show
Todd Rader added a comment - Server, agent, or both?
Hide
Todd Rader added a comment -

In the agent, as long as ojdbc6.jar works with Java 5, we're fine (I believe Jason has found an Oracle FAQ answer that claims it does indeed work with Java 5).

Show
Todd Rader added a comment - In the agent, as long as ojdbc6.jar works with Java 5, we're fine (I believe Jason has found an Oracle FAQ answer that claims it does indeed work with Java 5).
Hide
Todd Rader added a comment -

Bumping up to critical, due to license generation rules, this needs to be taken care of soon.

Show
Todd Rader added a comment - Bumping up to critical, due to license generation rules, this needs to be taken care of soon.
Hide
David Crutchfield added a comment -

FYI the ojdbc6.jar did not appear to work with java 1.5, so I'm going to use the ojdbc5.jar which seems to work with both java versions.

Show
David Crutchfield added a comment - FYI the ojdbc6.jar did not appear to work with java 1.5, so I'm going to use the ojdbc5.jar which seems to work with both java versions.

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    3 years, 1 week, 6 days ago