Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

org.hyperic.hq.appdef.server.session.AIQSynchronizer.sync runs on every page

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.5.1.2
  • Fix Version/s: 4.5.2, 4.6, 4.x Sprint 17
  • Component/s: Deprecated: UI
  • Environment:
    4.5.1.2 with mysql backend
  • Case Links:
    none
  • Regression:
    No
  • Story Points:
    5
  • Tags:

Description

To reproduce:

Add a resource in AIQ by either configuring a new agent and not approving it or by changing server property and leaving the modified change in AIQ (dashboard portlet)

Login to UI and load any page
Note that for ever page load following info message is printed in server.log. On all pages I see browser spinning for a while after entire page is visible in UI and it stops spinning as soon as following message is printed.

By default upto 5 platform messages are printed (since default AD portlet list size is 5) but could be worst if someone sets it to All.

2011-02-17 13:20:37,292 INFO [tomcat-http--32233] [org.hyperic.hq.appdef.server.session.AIQSynchronizer@114] Updating existing platform: kparikh-winxp1.eng.vmware.com

Activity

Patrick Nguyen added a comment -

org.hyperic.hq.ui.action.portlet.autoDisc.ViewAction is being called on every page and it's a mystery to me why and how this is happening.

Patrick Nguyen added a comment -

even worse. it looks like the DashboardLayout.jsp is being called on every page, including non-dashboard pages.

Jason Konicki added a comment -

Removing 4.5.1.4 as fixed release and adding 4.5.2 (since that is what 4.5.1.4 became)


People

Vote (0)
Watch (2)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 48 weeks, 2 days ago