Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Deleted VMs cause error in agent log, takes 15 minutes to be removed from inventory

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Trivial Trivial
  • Resolution: Deferred
  • Affects Version/s: 4.5.1.3
  • Fix Version/s: None
  • Component/s: Agent / PDK
  • Environment:
    4.5.1.3
  • Case Links:
    none
  • Regression:
    No

Description

If a VM that is monitored by vCenter plugin is removed from VC it causes HQ agent to throw error messages. Agent takes upto 15 minutes before it removes the VM from server inventory. That causes VM to showup as down (backfilled with 0 availability) in HQ.

For example when HQ-4.5-Agent-VM-B-9 was removed it logged following errors in agent log.

2011-02-18 18:18:22,385 ERROR [pool-1-thread-35] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@150] Error setting availability for HQ-4.5-Agent-VM-B-9: com.vmware.vim25.ManagedObjectNotFound
2011-02-18 18:19:24,640 ERROR [pool-1-thread-92] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@150] Error setting availability for HQ-4.5-Agent-VM-B-9: com.vmware.vim25.ManagedObjectNotFound
2011-02-18 18:20:11,141 ERROR [pool-1-thread-14] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@150] Error setting availability for HQ-4.5-Agent-VM-B-9: com.vmware.vim25.ManagedObjectNotFound
2011-02-18 18:21:07,567 ERROR [pool-1-thread-96] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@150] Error setting availability for HQ-4.5-Agent-VM-B-9: com.vmware.vim25.ManagedObjectNotFound
2011-02-18 18:23:08,550 ERROR [pool-1-thread-85] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@150] Error setting availability for HQ-4.5-Agent-VM-B-9: com.vmware.vim25.ManagedObjectNotFound
2011-02-18 18:25:15,158 ERROR [pool-1-thread-59] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@150] Error setting availability for HQ-4.5-Agent-VM-B-9: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
2011-02-18 18:25:15,159 DEBUG [pool-1-thread-59] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@151] org.hyperic.hq.plugin.vsphere.ManagedEntityNotFoundException: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
org.hyperic.hq.plugin.vsphere.ManagedEntityNotFoundException: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found

Then it removes the VM from HQ inventory

2011-02-18 18:25:37,093 DEBUG [Thread-3] [org.hyperic.hq.plugin.vsphere.VMAndHostVCenterPlatformDetector@788] Resource [id=12310, name=HQ-4.5-Agent-VM-B-9 {42284e04-6ba5-b7d3-5269-12c30576000b}] no longer exists in vCenter.  Removing from HQ inventory.

Agent still tries to collect metric since server doesn't send un-schedule request for couple of minutes.

2011-02-18 18:25:37,093 DEBUG [Thread-3] [org.hyperic.hq.plugin.vsphere.VMAndHostVCenterPlatformDetector@788] Resource [id=12310, name=HQ-4.5-Agent-VM-B-9 {42284e04-6ba5-b7d3-5269-12c30576000b}] no longer exists in vCenter.  Removing from HQ inventory.
2011-02-18 18:26:05,619 ERROR [pool-1-thread-60] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@150] Error setting availability for HQ-4.5-Agent-VM-B-9: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
2011-02-18 18:26:05,620 DEBUG [pool-1-thread-60] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@151] org.hyperic.hq.plugin.vsphere.ManagedEntityNotFoundException: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
org.hyperic.hq.plugin.vsphere.ManagedEntityNotFoundException: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
2011-02-18 18:27:01,613 ERROR [pool-1-thread-18] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@150] Error setting availability for HQ-4.5-Agent-VM-B-9: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
2011-02-18 18:27:01,614 DEBUG [pool-1-thread-18] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@151] org.hyperic.hq.plugin.vsphere.ManagedEntityNotFoundException: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
org.hyperic.hq.plugin.vsphere.ManagedEntityNotFoundException: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
2011-02-18 18:27:38,135 ERROR [pool-1-thread-88] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@150] Error setting availability for HQ-4.5-Agent-VM-B-9: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
2011-02-18 18:27:38,136 DEBUG [pool-1-thread-88] [org.hyperic.hq.plugin.vsphere.VSphereHostCollector@151] org.hyperic.hq.plugin.vsphere.ManagedEntityNotFoundException: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found
org.hyperic.hq.plugin.vsphere.ManagedEntityNotFoundException: VirtualMachine/HQ-4.5-Agent-VM-B-9: not found

Activity

Idan Hod added a comment -

As part of our continuous effort to improve product quality, The Hyperic product team has decided to implement a "zero bug policy" methodology.

Following this methodology, only defects that are planned to be handled in the near future will remain open. Any other defect will be deferred, with the option to be reevaluated if the need arises, or if changes to the Hyperic road-map make such defect a candidate for a fix.

We believe this new process will help create clarity and focus in the Hyperic road-map and ultimately benefit our customer base.

This bug has been deferred as part of the new policy.

We appreciate your cooperation and continues contribution to the improvement of Hyperic.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    41 weeks ago