Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Server should make sure the JRE being used is at least 1.6

Details

  • Type: Improvement Improvement
  • Status: Reopened Reopened
  • Priority: Major Major
  • Resolution: Unresolved
  • Affects Version/s: 4.5, 4.5.1.1
  • Fix Version/s: 4.5.1.3
  • Component/s: Deprecated: Server
  • Case Links:
    none
  • Regression:
    No
  • Tags:

Description

We should be enforcing the use of JRE 1.6 for the server. If it is not at least 1.6, we should print a message to the user and not try to start the server.

Issue Links

Activity

Hide
Jason Konicki added a comment -

Added Java version check to hq-server.sh and hq-server.bat.

Show
Jason Konicki added a comment - Added Java version check to hq-server.sh and hq-server.bat.
Hide
Kashyap Parikh added a comment -

Looks good on linux ->

[workerb@qaxen01 server-4.5.1.3.BUILD-SNAPSHOT-EE]$ export HQ_JAVA_HOME=/home/workerb/jdk1.5.0_12
[workerb@qaxen01 server-4.5.1.3.BUILD-SNAPSHOT-EE]$ ./bin/hq-server.sh start
Java version must be at least 1.6.
[workerb@qaxen01 server-4.5.1.3.BUILD-SNAPSHOT-EE]$

Show
Kashyap Parikh added a comment - Looks good on linux -> [workerb@qaxen01 server-4.5.1.3.BUILD-SNAPSHOT-EE]$ export HQ_JAVA_HOME=/home/workerb/jdk1.5.0_12 [workerb@qaxen01 server-4.5.1.3.BUILD-SNAPSHOT-EE]$ ./bin/hq-server.sh start Java version must be at least 1.6. [workerb@qaxen01 server-4.5.1.3.BUILD-SNAPSHOT-EE]$
Hide
Kashyap Parikh added a comment -

Looks fine on windows too

C:\hq\hyperic-hqee-installer-4.5.1.3.BUILD-SNAPSHOT>c:\hq\hyperic-hqee-installer-4.5.1.3.BUILD-SNAPSHOT\server-4.5.1.3.BUILD-SNAPSHOT-EE\bin\hq-server.bat start
Java version must be at least 1.6
Press any key to continue . . .

Show
Kashyap Parikh added a comment - Looks fine on windows too C:\hq\hyperic-hqee-installer-4.5.1.3.BUILD-SNAPSHOT>c:\hq\hyperic-hqee-installer-4.5.1.3.BUILD-SNAPSHOT\server-4.5.1.3.BUILD-SNAPSHOT-EE\bin\hq-server.bat start Java version must be at least 1.6 Press any key to continue . . .
Hide
Eyal Maderer added a comment -

Not working any more.

Show
Eyal Maderer added a comment - Not working any more.

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Last comment:
    2 years, 8 weeks, 4 days ago