Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Enable JIT by default on agent JRE (painful performance issue)

Details

  • Type: Improvement Improvement
  • Status: Closed Closed
  • Priority: Trivial Trivial
  • Resolution: Fixed
  • Affects Version/s: 4.3, 4.3.0.1, 4.4, 4.4.0.1, 4.5, 4.5.1, 4.5.1.1
  • Fix Version/s: 4.6.5
  • Component/s: Agent / PDK
  • Environment:
    agent, all
  • Case Links:
    none
  • Regression:
    No
  • Tags:

Description

The agent ships with the JIT disabled by default. Re-enable if no compelling issues are found.

Activity

Kashyap Parikh added a comment -

This is related to Java service wrapper setting jvm parameters and is even a bigger issue for server. Most likely this got in server because of copy-paster. Here's what wrapper.conf has on agent and server side.

wrapper.java.additional.1=-Djava.compiler=NONE

Wes Schlichter added a comment -

Changed wrapper.conf for agent and bootstrap to no longer specify java.compiler=NONE


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 29 weeks, 1 day ago