Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Cannot configure mysql Caused by: org.hyperic.hq.measurement.monitor.LiveMeasurementException:

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.5.1.3, 4.6
  • Fix Version/s: 4.6, 4.x Sprint 24
  • Component/s: Plugins
  • Environment:
    Version 4.6.0.BUILD-SNAPSHOT-2011-03-29,Platform:Linux DB:Oracle
  • Case Links:
    none
  • Regression:
    Yes
  • Story Points:
    3
  • Tags:

Description

Steps to reproduce

Install and start HQ-Server on VM1
Install and Start HQ Agent on VM2 (which has mysql db running)
Add to Inventory
Go to MYSQL server
Click Configure
Add all the required parameters
Click OK

Actual Results:
The configuration has not been set for this resource due to : Invalid configuration: Error retrieving value: Service mysqlstats:query=show /*!50002 global */ status,{}:Slow_queries not found: queryKey, null was not represented in the query

Agent log

2011-03-30 15:06:25,004 INFO [Thread-2] [RuntimeAutodiscoverer] SpringSource tc Runtime 6.0 discovery took 0.12
2011-03-30 15:06:27,118 ERROR [Thread-1] [MeasurementCommandsService] Error getting real time measurement: Error retrieving value: Service mysqlstats:query=show /*!50002 global */ status,{}:Slow_queries not found: Could not create connection to database server. Attempted reconnect 3 times. Giving up.
2011-03-30 15:06:35,150 ERROR [Thread-1] [MeasurementCommandsService] Error getting real time measurement: Error retrieving value: Service mysqlstats:query=show /*!50002 global */ status,{}:Created_tmp_files not found: Could not create connection to database server. Attempted reconnect 3 times. Giving up.
2011-03-30 15:06:39,164 ERROR [Thread-1] [MeasurementCommandsService] Error getting real time measurement: Error retrieving value: Service mysqlstats:query=show /*!50002 global */ status,{}:Created_tmp_disk_tables not found: Could not create connection to database server. Attempted reconnect 3 times. Giving up.

Activity

Kashyap Parikh added a comment -

Seems like server is not sending password to agent. Here's the error in agent.log

2011-03-31 20:21:12,610 ERROR [Thread-3] [RuntimeAutodiscoverer] Unexpected error running autodiscoverer for plugin: MySQL Stats 5.1.x: java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)
org.hyperic.hq.product.PluginException: java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)
        at org.hyperic.hq.plugin.mysql_stats.MySqlServerDetector.discoverServices(MySqlServerDetector.java:125)
        at org.hyperic.hq.product.ServerDetector.discoverResources(ServerDetector.java:219)
        at org.hyperic.hq.autoinventory.agent.server.RuntimeAutodiscoverer.doRuntimeScan_internal(RuntimeAutodiscoverer.java:272)
        at org.hyperic.hq.autoinventory.agent.server.RuntimeAutodiscoverer.doRuntimeScan(RuntimeAutodiscoverer.java:205)
        at org.hyperic.hq.autoinventory.ScanManager.mainRunLoop(ScanManager.java:165)
        at org.hyperic.hq.autoinventory.ScanManager.access$000(ScanManager.java:41)
        at org.hyperic.hq.autoinventory.ScanManager$1.run(ScanManager.java:107)
Caused by: java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)
        at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1055)
        at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:956)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3558)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3490)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:919)
        at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3996)
        at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1284)
        at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2142)
        at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:781)
        at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:348)
        at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:284)
        at org.hyperic.hq.plugin.mysql_stats.MySqlServerDetector.getConnection(MySqlServerDetector.java:192)
        at org.hyperic.hq.plugin.mysql_stats.MySqlServerDetector.discoverServices(MySqlServerDetector.java:120)
2011-03-31 20:21:12,610 ERROR [Thread-3] [RuntimeAutodiscoverer] Unexpected error running autodiscoverer for plugin: MySQL Stats 5.1.x: java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)
org.hyperic.hq.product.PluginException: java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)
        at org.hyperic.hq.plugin.mysql_stats.MySqlServerDetector.discoverServices(MySqlServerDetector.java:125)
        at org.hyperic.hq.product.ServerDetector.discoverResources(ServerDetector.java:219)
        at org.hyperic.hq.autoinventory.agent.server.RuntimeAutodiscoverer.doRuntimeScan_internal(RuntimeAutodiscoverer.java:272)
        at org.hyperic.hq.autoinventory.agent.server.RuntimeAutodiscoverer.doRuntimeScan(RuntimeAutodiscoverer.java:205)
        at org.hyperic.hq.autoinventory.ScanManager.mainRunLoop(ScanManager.java:165)
        at org.hyperic.hq.autoinventory.ScanManager.access$000(ScanManager.java:41)
        at org.hyperic.hq.autoinventory.ScanManager$1.run(ScanManager.java:107)
Caused by: java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)
        at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1055)
        at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:956)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3558)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3490)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:919)
        at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3996)
        at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1284)
        at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2142)
        at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:781)
        at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:348)
        at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:284)
        at org.hyperic.hq.plugin.mysql_stats.MySqlServerDetector.getConnection(MySqlServerDetector.java:192)
        at org.hyperic.hq.plugin.mysql_stats.MySqlServerDetector.discoverServices(MySqlServerDetector.java:120)
Kashyap Parikh added a comment -

Looks similar to

Dharma Srinivasan added a comment -

Observed the same on 4.5.1.3.

Patrick Nguyen added a comment -

FIX: Variable substitution for ${properties} doesn't seem to work for the template, so just use the actual values instead


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 44 weeks, 1 day ago