Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

HQ cannot function correctly without the hq-plugins dir, lots of NPEs

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Trivial Trivial
  • Resolution: Fixed
  • Affects Version/s: 4.6
  • Fix Version/s: 4.6, 4.x Sprint 14
  • Component/s: None
  • Case Links:
    none
  • Regression:
    No

Description

in PluginManagerImpl

public File getServerPluginDir() throws IOException { return ctx.getResource("WEB-INF/" + PLUGIN_DIR).getFile(); }

should throw a SystemException (or RuntimeException) if this dir doesn't exist and therefore halt HQ from starting up altogether. If this dir does not exist during initial startup there will be lots of NPEs around the app since no AppdefTypes and Resource ProtoTypes exist making HQ unusable. Currently we can't do this since the unittests will fail.

I think there are two possible solutions:

1) mock out this method for unittests so that the app context can be bootstrapped
2) fix all the areas where NPEs are thrown when no Resource Prototypes exist

Activity

Scott Feldstein added a comment -

added hq-plugins to hqee-integration-tests so that unittests don't fail

Yoav Epelman added a comment -

Didn't see it anymore


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 6 weeks, 5 days ago