Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

HQ Server Upgrade 4.5 -> 4.6 (MySQL backend) has database index & constraint differences after upgrade

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Blocker Blocker
  • Resolution: Fixed
  • Affects Version/s: 4.6, 4.x Sprint 21
  • Fix Version/s: 4.6, 4.x Sprint 23
  • Environment:
    MySQL Database, Upgrade from 4.5 to 4.6
  • Case Links:
    none
  • Regression:
    No
  • Tags:

Description

Perform 4.6 HQ server upgrade from 4.5 HQ server with MySQL Database.

Following database index and constraint differences are found (Please refer https://build.springsource.com/browse/HQEE-MYSQLUPGRADETEST-JOB1-32):

junit.framework.AssertionFailedError: — D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\upgradedb32.constraints +++ D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\freshdb32.constraints @@ -6,11 +6,12 @@ AGENTTOKEN,EAM_AGENT,AGENTTOKEN,1,(), FKE5AFD057CCBE6E,EAM_AGENT,AGENT_TYPE_ID,1,EAM_AGENT_TYPE, PRIMARY,EAM_AGENT,ID,1,(), +FK8C8FAC96559691A3,EAM_AGENT_PLUGIN_STATUS,AGENT_ID,1,EAM_AGENT, PRIMARY,EAM_AGENT_PLUGIN_STATUS,ID,1,(), PRIMARY,EAM_AGENT_TYPE,ID,1,(), AIQ_PLATFORM_ID,EAM_AIQ_IP,ADDRESS,2,(), @@ -375,379 +376,380 @@ PRIMARY,QRTZ_TRIGGER_LISTENERS,TRIGGER_GROUP,2,(), PRIMARY,QRTZ_TRIGGER_LISTENERS,TRIGGER_LISTENER,3,(), PRIMARY,QRTZ_TRIGGER_LISTENERS,TRIGGER_NAME,1,(), -rows: 375 +rows: 376
junit.framework.AssertionFailedError: — D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\upgradedb32.constraints
+++ D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\freshdb32.constraints
@@ -6,11 +6,12 @@
AGENTTOKEN,EAM_AGENT,AGENTTOKEN,1,(),
FKE5AFD057CCBE6E,EAM_AGENT,AGENT_TYPE_ID,1,EAM_AGENT_TYPE,
PRIMARY,EAM_AGENT,ID,1,(),
+FK8C8FAC96559691A3,EAM_AGENT_PLUGIN_STATUS,AGENT_ID,1,EAM_AGENT,
PRIMARY,EAM_AGENT_PLUGIN_STATUS,ID,1,(),
PRIMARY,EAM_AGENT_TYPE,ID,1,(),
AIQ_PLATFORM_ID,EAM_AIQ_IP,ADDRESS,2,(),
@@ -375,379 +376,380 @@
PRIMARY,QRTZ_TRIGGER_LISTENERS,TRIGGER_GROUP,2,(),
PRIMARY,QRTZ_TRIGGER_LISTENERS,TRIGGER_LISTENER,3,(),
PRIMARY,QRTZ_TRIGGER_LISTENERS,TRIGGER_NAME,1,(),
-rows: 375
+rows: 376

+++ D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\freshdb32.constraints
@@ -6,11 +6,12 @@
AGENTTOKEN,EAM_AGENT,AGENTTOKEN,1,(),
FKE5AFD057CCBE6E,EAM_AGENT,AGENT_TYPE_ID,1,EAM_AGENT_TYPE,
PRIMARY,EAM_AGENT,ID,1,(),
+FK8C8FAC96559691A3,EAM_AGENT_PLUGIN_STATUS,AGENT_ID,1,EAM_AGENT,
PRIMARY,EAM_AGENT_PLUGIN_STATUS,ID,1,(),
PRIMARY,EAM_AGENT_TYPE,ID,1,(),
AIQ_PLATFORM_ID,EAM_AIQ_IP,ADDRESS,2,(),
@@ -375,379 +376,380 @@
PRIMARY,QRTZ_TRIGGER_LISTENERS,TRIGGER_GROUP,2,(),
PRIMARY,QRTZ_TRIGGER_LISTENERS,TRIGGER_LISTENER,3,(),
PRIMARY,QRTZ_TRIGGER_LISTENERS,TRIGGER_NAME,1,(),
-rows: 375
+rows: 376

junit.framework.AssertionFailedError: — D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\upgradedb32.indexes +++ D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\freshdb32.indexes @@ -7,12 +7,13 @@ EAM_AGENT,0,PRIMARY,1,ID, EAM_AGENT,1,AGENT_TYPE_ID_IDX,1,AGENT_TYPE_ID, EAM_AGENT_PLUGIN_STATUS,0,PRIMARY,1,ID, +EAM_AGENT_PLUGIN_STATUS,1,AGENT_ID,1,AGENT_ID, EAM_AGENT_PLUGIN_STATUS,1,APS_FILE_NAME_IDX,1,FILE_NAME, EAM_AGENT_PLUGIN_STATUS,1,APS_MD5_IDX,1,MD5, EAM_AGENT_PLUGIN_STATUS,1,APS_PLUGIN_NAME_IDX,1,PLUGIN_NAME, @@ -10,16 +11,16 @@ EAM_AGENT_PLUGIN_STATUS,1,APS_FILE_NAME_IDX,1,FILE_NAME, EAM_AGENT_PLUGIN_STATUS,1,APS_MD5_IDX,1,MD5, EAM_AGENT_PLUGIN_STATUS,1,APS_PLUGIN_NAME_IDX,1,PLUGIN_NAME, -EAM_AGENT_PLUGIN_STATUS,1,FK8C8FAC96559691A3,1,AGENT_ID, EAM_AGENT_TYPE,0,PRIMARY,1,ID, EAM_AIQ_IP,0,AIQ_PLATFORM_ID,1,AIQ_PLATFORM_ID, EAM_AIQ_IP,0,AIQ_PLATFORM_ID,2,ADDRESS,
junit.framework.AssertionFailedError: — D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\upgradedb32.indexes
+++ D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\freshdb32.indexes
@@ -7,12 +7,13 @@
EAM_AGENT,0,PRIMARY,1,ID,
EAM_AGENT,1,AGENT_TYPE_ID_IDX,1,AGENT_TYPE_ID,
EAM_AGENT_PLUGIN_STATUS,0,PRIMARY,1,ID,
+EAM_AGENT_PLUGIN_STATUS,1,AGENT_ID,1,AGENT_ID,
EAM_AGENT_PLUGIN_STATUS,1,APS_FILE_NAME_IDX,1,FILE_NAME,
EAM_AGENT_PLUGIN_STATUS,1,APS_MD5_IDX,1,MD5,
EAM_AGENT_PLUGIN_STATUS,1,APS_PLUGIN_NAME_IDX,1,PLUGIN_NAME,
@@ -10,16 +11,16 @@
EAM_AGENT_PLUGIN_STATUS,1,APS_FILE_NAME_IDX,1,FILE_NAME,
EAM_AGENT_PLUGIN_STATUS,1,APS_MD5_IDX,1,MD5,
EAM_AGENT_PLUGIN_STATUS,1,APS_PLUGIN_NAME_IDX,1,PLUGIN_NAME,
-EAM_AGENT_PLUGIN_STATUS,1,FK8C8FAC96559691A3,1,AGENT_ID,
EAM_AGENT_TYPE,0,PRIMARY,1,ID,
EAM_AIQ_IP,0,AIQ_PLATFORM_ID,1,AIQ_PLATFORM_ID,
EAM_AIQ_IP,0,AIQ_PLATFORM_ID,2,ADDRESS,

+++ D:\bamboo-agent-home\xml-data\build-dir\HQEE-MYSQLUPGRADETEST-JOB1\upgrade-install\HQ-server-4.6.0-EE\20110518\server-4.6.0.BUILD-SNAPSHOT-EE\mysqlcompare\freshdb32.indexes
@@ -7,12 +7,13 @@
EAM_AGENT,0,PRIMARY,1,ID,
EAM_AGENT,1,AGENT_TYPE_ID_IDX,1,AGENT_TYPE_ID,
EAM_AGENT_PLUGIN_STATUS,0,PRIMARY,1,ID,
+EAM_AGENT_PLUGIN_STATUS,1,AGENT_ID,1,AGENT_ID,
EAM_AGENT_PLUGIN_STATUS,1,APS_FILE_NAME_IDX,1,FILE_NAME,
EAM_AGENT_PLUGIN_STATUS,1,APS_MD5_IDX,1,MD5,
EAM_AGENT_PLUGIN_STATUS,1,APS_PLUGIN_NAME_IDX,1,PLUGIN_NAME,
@@ -10,16 +11,16 @@
EAM_AGENT_PLUGIN_STATUS,1,APS_FILE_NAME_IDX,1,FILE_NAME,
EAM_AGENT_PLUGIN_STATUS,1,APS_MD5_IDX,1,MD5,
EAM_AGENT_PLUGIN_STATUS,1,APS_PLUGIN_NAME_IDX,1,PLUGIN_NAME,
-EAM_AGENT_PLUGIN_STATUS,1,FK8C8FAC96559691A3,1,AGENT_ID,
EAM_AGENT_TYPE,0,PRIMARY,1,ID,
EAM_AIQ_IP,0,AIQ_PLATFORM_ID,1,AIQ_PLATFORM_ID,
EAM_AIQ_IP,0,AIQ_PLATFORM_ID,2,ADDRESS,

Activity

Scott Feldstein added a comment -

The constraint names on EAM_AGENT_PLUGIN_STATUS btwn upgrade and fresh install aren't matching up..

Scott Feldstein added a comment -

I see where the problem was, it should be fine now.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 45 weeks, 5 days ago