Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

updated http client logs debug information instead of the error as set in agent.properties when agent.logLevel=DEBUG

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Trivial Trivial
  • Resolution: Fixed
  • Affects Version/s: 4.6
  • Fix Version/s: 4.6, 4.x Sprint 28
  • Component/s: Agent / PDK
  • Case Links:
    none
  • Regression:
    Yes
  • Story Points:
    2
  • Tags:

Description

when setting agent.logLevel=DEBUG in agent.properties the updated http client logs in DEBUG. It appears that the class names have changed in the updated http client

I changed

log4j.logger.httpclient.wire=ERROR
log4j.logger.org.apache.commons.httpclient=WARN

to

log4j.logger.org.apache.http=ERROR

and this seems to be working as expected.

Activity

Patrick Nguyen added a comment -

FIX: Only log errors from HTTP and REST classes

Idan Hod added a comment -

Hyperic 5.7 fixed ok


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 2 weeks ago