Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Error creating org.hyperic.hq.plugin.weblogic.WeblogicDetector: java.lang.InstantiationException

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.6, 4.x Sprint 27
  • Fix Version/s: 4.6, 4.x Sprint 28
  • Environment:
    Hyperic server 4.6.0-EE-244 on CentOS 5.4 x64 with embedded Postgres DB
    Hyperic agent 4.6.0-EE-244 on CentOS 5.4 x64
  • Case Links:
    none
  • Regression:
    No
  • Tags:

Description

Error creating org.hyperic.hq.plugin.weblogic.WeblogicDetector: java.lang.InstantiationException

After trying to upgrade the agent from an earlier 4.6.0 build (242) to later 4.6.0 build (244) via UI, I didn't see the upgraded bundle so began to look in the agent.log.

There were various results in agent.log for Error creating org.hyperic.hq.plugin.weblogic.WeblogicDetector: java.lang.InstantiationException.

See attached 'agent.log' file for full stack at 2011-07-20 16:30:15,786.

Expected Result:
No errors posted to agent.log

Actual Result:
Error posted to agent.log

Steps to Reproduce:
Unsure of exact steps to reproduce; error found while debugging why agent upgrade did not complete. Attempted agent upgrade via UI from earlier 4.6.0 build (242) to later 4.6.0 build (244).

Continuing research on failed upgrade; however, error message needs to be reported and investigated. DEV (PN) had also experienced this error on another environment.

Until further understanding why error is thrown and how it is reproduced, priority may not be correct.

Activity

Todd Rader added a comment -

This could be a regression caused by the merge.

German Laullon added a comment -

Bad hq-plugin.xml in the last merge.

Frederic Calindas added a comment -

Verified with Hyperic Server Daily Build 4.6.0-EE-252 (7/28/11) and upgraded agent via UI.

Reported error message not found.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 38 weeks, 1 day ago