Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

vSphere plugin - SSL configuration is lost with latest build and availability/metrics no longer report

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Blocker Blocker
  • Resolution: Fixed
  • Affects Version/s: 4.6, 4.x Sprint 27
  • Fix Version/s: 4.6, 4.x Sprint 28
  • Component/s: Plugins
  • Environment:
    Hyperic server 4.6.0-EE-245 on CentOS 5.4 x64 with external MySQL DB
    Hyperic agent 4.6.0-EE-245 on Windowws 2008
     - vCenter Server 4.0 running on agent platform
  • Case Links:
    none
  • Regression:
    No
  • Tags:

Description

vSphere plugin - SSL configuration is lost with latest build and availability/metrics no longer report

After upgrading the server with the latest build, the Plugin Manager upgraded the vSphere plugin to the latest and the vCenter server was no longer properly configured so availability and metrics were no longer reporting. Restarting the agent had no affect.

When installing a new agent and attempting to re-configure the properties, the properties would not succeed with 'unable to find valid certification path to requested target'.

The agent.log reported:

ERROR [pool-2-thread-1] [ScheduleThread] Metric unreachable while processing Metric 'VMware vCenter:vcenter:url=https%3A//10.150.29.72/sdk,user=administrator,pass=*******:ConnectionValidationTime'
org.hyperic.hq.product.MetricUnreachableException: ServiceInstance(https://10.150.29.72/sdk, administrator): java.rmi.RemoteException: VI SDK invoke exception:javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
 at org.hyperic.hq.plugin.vsphere.VCenterMeasurementPlugin.getValue(VCenterMeasurementPlugin.java:54)
 at org.hyperic.hq.product.MeasurementPluginManager.getPluginValue(MeasurementPluginManager.java:176)
 at org.hyperic.hq.product.MeasurementPluginManager.getValue(MeasurementPluginManager.java:274)
 at org.hyperic.hq.measurement.agent.server.ScheduleThread.getValue(ScheduleThread.java:439)
 at org.hyperic.hq.measurement.agent.server.ScheduleThread.access$1400(ScheduleThread.java:75)
 at org.hyperic.hq.measurement.agent.server.ScheduleThread$MetricTask.run(ScheduleThread.java:505)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
 at java.lang.Thread.run(Thread.java:619)
Caused by: org.hyperic.hq.product.PluginException: ServiceInstance(https://10.150.29.72/sdk, administrator): java.rmi.RemoteException: VI SDK invoke exception:javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
 at org.hyperic.hq.plugin.vsphere.VSphereUtil.getInstance(VSphereUtil.java:113)
 at org.hyperic.hq.plugin.vsphere.VCenterMeasurementPlugin.getValue(VCenterMeasurementPlugin.java:43)
 ... 11 more
Caused by: java.rmi.RemoteException: VI SDK invoke exception:javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
 at com.vmware.vim25.ws.WSClient.invoke(WSClient.java:176)
 at com.vmware.vim25.ws.WSClient.invoke(WSClient.java:119)
 at com.vmware.vim25.ws.VimStub.retrieveServiceContent(VimStub.java:1341)
 at com.vmware.vim25.mo.ServiceInstance.<init>(ServiceInstance.java:85)
 at com.vmware.vim25.mo.ServiceInstance.<init>(ServiceInstance.java:69)
 at org.hyperic.hq.plugin.vsphere.VSphereUtil.<init>(VSphereUtil.java:83)
 at org.hyperic.hq.plugin.vsphere.VSphereUtil.getInstance(VSphereUtil.java:111)
 ... 12 more

Expected Result:
Upgrade of new vSphere plugin contineus functionality; no errors reported

Actual Result:
Upgrade of new vSphere plugin stops availability/metrics collection;unable to configure configuration

Steps to Reproduce:

  1. Setup and configure older agent build (7/18/11) on platform running vCenter
  2. Note plugin is working
  3. Upgrade server to latest build (7/20/11)
  4. Note Availability and Metrics for vCenter Server stop collecting

Additional Information:
Reverting to plugin from agent build (7/18/11) works

Issue Links

Activity

Patrick Nguyen added a comment -

caused by HHQ-5079

Patrick Nguyen added a comment -

HHQ-5079 fixed

Frederic Calindas added a comment -

Verified with server build 247 and agent build 248 (7/22/11).

After upgrading the server, the vSphere plugin was pushed to the agent, the Availability and Metrics for the vCenter server which were previously unreporting unavailable and no metrics started showing as available and collecting metrics.

Upgrading the agent via UI still collected correct availability and metrics. Changes made to the configuration properties were accepted and successfully saved.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 38 weeks, 5 days ago