Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Plugin Manager - upgrade agent from 4.5.2 to 4.6.0 does not update sync status

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.6
  • Fix Version/s: 4.6, 4.x Sprint 28
  • Environment:
    Hyperic Server Daily Build 4.6.0-EE-247 (7/22/11) on CentOS 5.4 x64 with external MySQL DB
    Hyperic Agent Daily Build upgraded from 4.5.2 to 4.6.0-EE-247 (7/22/11) on CentOS 5.4 x64
  • Case Links:
    none
  • Regression:
    No
  • Story Points:
    5
  • Tags:

Description

Plugin Manager - upgrade agent from 4.5.2 to 4.6.0 does not update sync status

After upgrading a fresh install of 4.5.2 to 4.6.0, the Plugin Manager reports the newly upgraded agent as a manageable agent.

The Plugin Table does not sync or show updated sync status with the newly added agent.

Expected Result:
The Plugin Manager should show Sync Status for newly upgraded agents which matches number of Manageable Agents

Actual Result:
The Plugin Manager does not show Sync Status for newly upgrade agents; the number of sync status and Manageable Agents do not match

Steps to Reproduce:

  1. Install 4.5.2 agent and connect to 4.6.0 server
  2. Note number of Manageable Agents in Plugin Manager
  3. Note number of Sync Status in Plugin Manager
  4. Upgrade 4.5.2 agent via UI
  5. Note number of Manageable Agents in Plugin Manager
  6. Note number of Sync Status in Plugin Manager
  7. Note Sync Status not changed after upgraded agent

Activity

Scott Feldstein added a comment -

Looks like we were never handling that bag properly. The pluginManager recently started using it to determine if an agent had an associated platforms and then show it in the UI if true.

It works now. Please test platform add and delete.

Frederic Calindas added a comment -

Verified with Hyperic Server Daily Build 4.6.0-EE-252 (7/28/11).

Installed fresh agent of Hyperic agent 4.5.2-EE on RHEL 5.4 x64 and upgraded via UI. Agent Sync Status in Plugin Manager properly updated to reflect newly upgraded agent.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 38 weeks, 5 days ago