Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Agent.log reports ERROR [Poller Client] [PollerClientImpl$PollingRunnable] Error connecting the undirection poller client to the hq server: java.lang.reflect.InvocationTargetException

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Deferred
  • Affects Version/s: 4.6
  • Fix Version/s: None
  • Component/s: Agent / PDK
  • Environment:
    Hyperic server daily build 4.6.0-EE-254 (7/29/11) on CentOS 5.4 x64 with embedded Postgres DB
    Hyperic agent daily build 4.6.0-EE-256 (7/29/11) on RHEL 5.5 x64

Description

Agent.log reports ERROR [Poller Client] [PollerClientImpl$PollingRunnable] Error connecting the undirection poller client to the hq server: java.lang.reflect.InvocationTargetException

After installing latest Server build (from 7/29/11) and upgrading the agent via UI, I noticed the RabbitMQ and Apache Servers were not configured even though they were configured pre-upgrade. Looking at the log shows the following error:

2011-07-29 11:07:17,653 ERROR [Poller Client] [PollerClientImpl$PollingRunnable] Error connecting the undirection poller client to the hq server: java.lang.reflect.InvocationTargetException
java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor15.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.jboss.remoting.InvokerRegistry.loadClientInvoker(InvokerRegistry.java:419)
	at org.jboss.remoting.InvokerRegistry.createClientInvoker(InvokerRegistry.java:320)
	at org.jboss.remoting.Client.connect(Client.java:459)
	at org.jboss.remoting.transporter.TransporterClient.<init>(TransporterClient.java:86)
	at org.jboss.remoting.transporter.TransporterClient.createTransporterClient(TransporterClient.java:237)
	at com.hyperic.hq.transport.PollerClientImpl$PollingRunnable.connectToPollerService(PollerClientImpl.java:219)
	at com.hyperic.hq.transport.PollerClientImpl$PollingRunnable.run(PollerClientImpl.java:190)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: Unable to create customized SSL socket factory
	at org.jboss.remoting.AbstractInvoker.createSocketFactory(AbstractInvoker.java:343)
	at org.jboss.remoting.transport.http.ssl.HTTPSClientInvoker.createSocketFactory(HTTPSClientInvoker.java:129)
	at org.jboss.remoting.RemoteClientInvoker.<init>(RemoteClientInvoker.java:46)
	at org.jboss.remoting.transport.http.HTTPClientInvoker.<init>(HTTPClientInvoker.java:107)
	at org.jboss.remoting.transport.http.ssl.HTTPSClientInvoker.<init>(HTTPSClientInvoker.java:63)
	at com.hyperic.hq.transport.SSLTransportClientFactory.createClientInvoker(SSLTransportClientFactory.java:40)
	... 11 more
Caused by: java.io.IOException: Error initializing socket factory SSL context: Can not find key entry for key store (file:/opt/hyperic/4.6.0-EE-246/hyperic-hqee-agent-4.6.0.BUILD-SNAPSHOT/wrapper/sbin/../../data/keystore) with given alias (hq)
	at org.jboss.remoting.security.SSLSocketBuilder.loadKeyManagers(SSLSocketBuilder.java:1455)
	at org.jboss.remoting.security.SSLSocketBuilder.initializeSocketFactorySSLContext(SSLSocketBuilder.java:1314)
	at org.jboss.remoting.security.SSLSocketBuilder.createCustomSocketFactory(SSLSocketBuilder.java:451)
	at org.jboss.remoting.security.SSLSocketBuilder.createSSLSocketFactory(SSLSocketBuilder.java:431)
	at org.jboss.remoting.security.SSLSocketBuilder.createSSLSocketFactory(SSLSocketBuilder.java:381)
	at org.jboss.remoting.AbstractInvoker.createSocketFactory(AbstractInvoker.java:338)
	... 16 more

There is no JBoss installed on this platform but there is Apache 2.2.3 and RabbitMQ 2.5.1.

Expected Result:
No errors reported and servers can be configured which were previously configured

Actual Result:
Error reported and cannot configure RabbitMQ and Apache Servers

Steps to Reproduce:

  1. On existing environment with agent monitoring Apache and/or RabbitMQ, upgrade agent to latest build (7/29/11)
  2. Note Apache and RabbitMQ servers auto-discovered as modified
  3. Note configuration for Apache and RabbitMQ lost
  4. Attempt to re-cofnigure Apache and RabbitMQ
  5. Examine agent.log
  6. Note reported error

Activity

Frederic Calindas added a comment -

After reconfiguring the agent to use bi-directional communication, the error was no longer reported. We still need to be able to run agents with both bi and uni-directional communication.

David Wiener added a comment -

Will try to reproduce. If we cannot reproduce then will move it out of 5.0


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 29 weeks, 1 day ago