Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

RabbitMQ plugin - The configuration has not been set for this resource due to : Invalid configuration: Error reported by Agent @ 10.16.17.68:-1: Timeout occurred waiting on agent response.

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.6
  • Fix Version/s: 4.6, 4.x Sprint 28
  • Component/s: Plugins
  • Environment:
    Hyperic server daily build 4.6.0-EE-254 (7/29/11) on CentOS 5.4 x64 with embedded Postgres DB
    Hyperic agent daily build 4.6.0-EE-256 (7/29/11) on RHEL 5.5 x64 with RabbitMQ 2.5.1 running SSL
  • Case Links:
    none
  • Regression:
    No
  • Story Points:
    5
  • Tags:

Description

RabbitMQ plugin - The configuration has not been set for this resource due to : Invalid configuration: Error reported by Agent @ 10.16.17.68:-1: Timeout occurred waiting on agent response.

Cannot configure RabbitMQ server with agent running uni-directional communcation.

After upgrading to the latest build (7/29/11), the existing RabbitMQ server was auto-discovered as modified. After adding the server to inventory from AIQ, the server was not configured. Attempting to set and save Configuration Properties for the RabbitMQ server resulted in error:

The configuration has not been set for this resource due to : Invalid configuration: Error reported by Agent @ 10.16.17.68:-1: Timeout occurred waiting on agent response.

There is an error in the agent.log but not sure if it's related.

See attached agent.log and server.log.

Expected Result:
Upgrading agent maintains existing server configuration and remains functional

Actual Result:
Upgrading agent does not maintain existing server configuration and cannot be configured; server not monitored

Steps to Reproduce:

  1. On existing environment with agent monitoring RabbitMQ, upgrade agent to latest build (7/29/11)
  2. Note RabbitMQ server auto-discovered as modified
  3. Add RabbitMQ server into inventory from AIQ
  4. Note configuration for RabbitMQ not maintained
  5. Attempt to re-configure and save RabbitMQ properties
  6. Note reported error
  1. agent.log
    29/Jul/11 8:32 AM
    1.98 MB
    Frederic Calindas
  2. server.log
    29/Jul/11 8:32 AM
    2.14 MB
    Frederic Calindas

Activity

Frederic Calindas added a comment -

After further investigation, someone had changed the agent to communicate in uni-diretional communcation. Setting it back to use bi-directional communcation, the configuration was accepted and saved successfully.

There is still a problem with agent running uni-directional and RabbitMQ could not be configured.

German Laullon added a comment -

This Timeout is caused when the RabbitMQ plugin is trying to access to a RabbitMQ server with SSL, the plugin is trying to detect if there is new services during the runtimeScan.

This feature can be disabled by adding this to the agent.property file:
rabbitmq.disable.runtimeScan=true

The new services will be discovered on the next defaultScan.

Todd Rader added a comment -

I don't see any evidence of RabbitMQ being in play here. The agent-side InvocationTargetExceptions are addressed by another bug, and they look like the cause of the server-side timeout exceptions.

Frederic Calindas added a comment -

Verified with Hyperic Server 4.6.0-EE-RC1 (8/2/11) on CentOS 5.4 x64 with embedded PostgreSQL DB.

Hyperic agent was installed on platform (RHEL 5.5 x64) running RabbitMQ 2.5.1 using SSL and with uni-directional communication.

Platform monitoring including RabbitMQ was functional and reported error not found in log.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 37 weeks, 5 days ago