Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

WebSphere plugin - Unable to configure WebSphere 6.1; The configuration has not been set for this resource due to : Invalid configuration: Error contacting resource: The WebSphere plugin needs a IBM JVM !!! (agent jvm=Sun Microsystems Inc.)

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Deferred
  • Affects Version/s: 4.6, 5.0
  • Fix Version/s: None
  • Component/s: Agent / PDK
  • Environment:
    Hyperic server 4.6.0-EE-RC1 on CentOS 5.4 x64 with embedded PostgreSQL DB
    Hyperic agent 4.6.0-EE_RC1 on Windows 2003 with WebSphere 6.1

Description

WebSphere plugin - Unable to configure WebSphere 6.1; The configuration has not been set for this resource due to : Invalid configuration: Error contacting resource: The WebSphere plugin needs a IBM JVM !!! (agent jvm=Sun Microsystems Inc.)

After installing and starting Hyperic agent on Windows 2003 running WebSphere 6.1, I am unable to configure the Configuration Properties. Attempting to set values results in:

The configuration has not been set for this resource due to :b Invalid configuration: Error contacting resource: The WebSphere plugin needs a IBM JVM !!! (agent jvm=Sun Microsystems Inc.)

The Hyperic agent was started with HQ_JAVA_HOME set to C:\sw\IBM\WebSphere\AppServer\java.
Also JAVA_HOME was set to the same.
Even setting HQ_JAVA_HOME at CLI before running hq-agent.bat start did not help.

The agent.properties is modified to include:

websphere.installpath=C:\sw\IBM\WebSphere\AppServer
websphere.useext=true

IBM JVM:
C:\WINDOWS>java -version
java version "1.5.0"
Java(TM) 2 Runtime Environment, Standard Edition (build pwa64dev-20091106a (SR11))
IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Windows Server 2003 amd64-64 j9vmwa6
423-20091104 (JIT enabled)
J9VM - 20091103_45935_LEdSMr
JIT - 20091016_1845_r8
GC - 20091026_AA)
JCL - 20091106

Expected Result:
Able to configure WebSphere Configuration Properties if agent started with IBM JVM.

Actual Result:
Unable to configure WebSphere Configuration Properties when agent started with IBM JVM.

Steps to Reproduce:

  1. Install Hyperic agent on platform (Windows 2003) running WebSphere 6.1
  2. Edit agent.properties to include websphere.useext=true and websphere.installpath=[path]
  3. Set HQ_JAVA_HOME to point to IBM JVM
  4. Start hq-agent
  5. Note platform running WebSphere 6.1 is auto-discovered in AIQ
  6. Add to inventory platform running WebSphere 6.1 from AIQ
  7. Note WebSphere services auto-discovered
  8. Attempt to configure WebSphere Configuration Properties
  9. Note reported error that WebSphere plugin needs IBM JVM

Activity

Hide
German Laullon added a comment -

I need the log with debug level.

Show
German Laullon added a comment - I need the log with debug level.
Hide
Frederic Calindas added a comment -

See attached agent.log with debug output.

Show
Frederic Calindas added a comment - See attached agent.log with debug output.
Hide
German Laullon added a comment -

The java-wrapper is not using HQ_JAVA_HOME value.

Work around:

Add the HQ_JAVA_HOME to the wrapper.conf file:

wrapper.java.command=PATH_TO_IBM_JRE

Show
German Laullon added a comment - The java-wrapper is not using HQ_JAVA_HOME value. Work around: Add the HQ_JAVA_HOME to the wrapper.conf file: wrapper.java.command=PATH_TO_IBM_JRE
Hide
German Laullon added a comment -

This is not a WebSphere plugin bug, is a problem on the agent startup process on windows.
HQ_JAVA_HOME is not used.

Show
German Laullon added a comment - This is not a WebSphere plugin bug, is a problem on the agent startup process on windows. HQ_JAVA_HOME is not used.
Hide
Idan Hod added a comment -

Bug court: has a workaround

Show
Idan Hod added a comment - Bug court: has a workaround

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    44 weeks, 1 day ago