Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Network Interface shows 100% when link is down

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: None
  • Fix Version/s: 4.6.5
  • Component/s: Plugins
  • Case Links:
    none
  • Regression:
    No
  • Tags:

Description

Found this in my own lab. Had a bad ethernet cable but system-plugin was reporting interface as 100% Available.

Steps to reproduce:

1.) Make sure agent is monitoring a network interface
2.) Disconnect network cable (in VCenter, this can be done by unchecking "Connected" for interface)
3.) Watch what system-plugin reports for Network Interface. It will show as 100% Available

Expected Results:

50% Availability reported since interface is still technically up, just not fully Available

Activity

Wes Schlichter added a comment -

Changed Availability for NetworkServer Interface to report 50% if link is unplugged.

Note to QA: While verifying my fix I came across an unusual sigar caching issue with NetIfconfig Flags. It made it appear that my fix wasn't working. I either had to restart the agent or just wait long enough for a new value to be returned by sigar. I'm working on tracking down that bug and will create a different bug report for that and link it to this jira.

Zvika Messing added a comment -

validated in hyperic-hqee-installer-4.6.5.BUILD-20120116.100442-15. network interface avaiability decrease when 1 of the network interfaces is down. and is back to 100% when all NICs are connected.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 12 weeks, 3 days ago