Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Configuration help in PostgreSQL plugin is out-of-date

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Trivial Trivial
  • Resolution: Fixed
  • Affects Version/s: 4.2.0, 4.3, 4.4, 4.5, 4.6, 4.6.5
  • Fix Version/s: 4.6.5
  • Component/s: None
  • Case Links:
    none
  • HQ Fix Version:
    4.6.5
  • 3.0 Category:
    Plugins
  • Regression:
    No

Description

an email to bugs@hyperic.org indicates that the help defined in the XML descriptor for the PostgreSQL plugin is OOD. It says to set PostgreSQL configuration settings that have not existed in PostgreSQL since v8.2. The descriptor needs updating to have different <help> for versions 8.3 on. It seems like no config is required to manage 8.3 and later.

Here's what the bug report said:

There are notes for the PostgreSQL plugin that note the following are required configuration settings:
stats_start_collector = true
stats_block_level = true
stats_row_level = true
and that
stats_reset_on_server_start = false
is optional.

As of PostgreSQL 8.4, these settings no longer exist. stats_start_collector was removed because the collector is always started, block level and row level are rolled up in to track_counts which defaults to on, and stats_reset was removed in favor of a function which performs the same task on demand.

Activity

Adar Margalit added a comment -

Updated documentation. This was fixed a while ago.

Maya Anderson added a comment -

Help for version 9.0 is outdated.

Adar Margalit added a comment -

Fixed in build 20120216


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 10 weeks, 1 day ago