Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Plugin Manager should only sync to agents that are >= to the server version

Details

  • Type: Improvement Improvement
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: None
  • Fix Version/s: 4.6.5
  • Component/s: None
  • Case Links:
    none
  • HQ Fix Version:
    4.6.5 Build of 07-Feb-2012
  • Regression:
    No

Description

If a server is 4.6.1, then it should only sync to an agent where the version is >= 4.6.1

Therefore these versions would match

4.6.1.1
4.6.1.2
4.6.2
4.6.2.5
4.7
4.8.1
5.0
...
...
etc...

This needs to somehow be reflected in the Plugin Manager UI

Activity

Hide
Maya Anderson added a comment -

The agent summary panel doesn't display correctly in IE9. Adding an additional bug regarding that.

Show
Maya Anderson added a comment - The agent summary panel doesn't display correctly in IE9. Adding an additional bug regarding that.
Hide
rivka pints (c) added a comment - - edited

Maya,

If we test one older version agent(4.6.0.1) will it good or we have to also test 4.5.x and 4.4.x .....

Show
rivka pints (c) added a comment - - edited Maya, If we test one older version agent(4.6.0.1) will it good or we have to also test 4.5.x and 4.4.x .....
Hide
Maya Anderson added a comment -

Hi Nipuna and Rivka,
Kindly test all the supported agents.

Show
Maya Anderson added a comment - Hi Nipuna and Rivka, Kindly test all the supported agents.
Hide
Maya Anderson added a comment -

Reopening by Scott's request:
4.6.5.x server should be compatible with agents that match:
4.6.5, 4.6.5.0, 4.6.5.1, 4.6.5.2, 4.6.5.3, 4.6.6, 4.6.6.0, 4.6.6.1, 4.7, 5.0.1.1 etc...

  • any agent that starts with the same x.x.x version as the server or higher.
Show
Maya Anderson added a comment - Reopening by Scott's request: 4.6.5.x server should be compatible with agents that match: 4.6.5, 4.6.5.0, 4.6.5.1, 4.6.5.2, 4.6.5.3, 4.6.6, 4.6.6.0, 4.6.6.1, 4.7, 5.0.1.1 etc...
  • any agent that starts with the same x.x.x version as the server or higher.
Hide
rivka pints (c) added a comment -

If i can to change manually the version of the Hyperic Agent before the installation?
for example to change version from 4.6.5 to 4.6.5.7 or 4.6.5.3 and etc.
What and where the changes need to do?

Show
rivka pints (c) added a comment - If i can to change manually the version of the Hyperic Agent before the installation? for example to change version from 4.6.5 to 4.6.5.7 or 4.6.5.3 and etc. What and where the changes need to do?
Hide
rivka pints (c) added a comment -

verified Version 4.6.5.BUILD-SNAPSHOT-2012-02-21
I installed server with 3 agents are different version.
(the agent version :4.6.5 ,4.5.1,4.6.5.3)
Plugin Manager synchronize to 4.6.5 and 4.6.5.3
succeed to add and update new plugins by the PM.

Show
rivka pints (c) added a comment - verified Version 4.6.5.BUILD-SNAPSHOT-2012-02-21 I installed server with 3 agents are different version. (the agent version :4.6.5 ,4.5.1,4.6.5.3) Plugin Manager synchronize to 4.6.5 and 4.6.5.3 succeed to add and update new plugins by the PM.

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 7 weeks, 5 days ago