Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

samba-plugin no longer jre 1.5 compatible

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.6.5
  • Fix Version/s: 4.6.5
  • Component/s: Plugins
  • Environment:
    no samba server present.
    Build from master December 8, 2011 latest commit 39afe08403db388971b66a52ebc1d65ebd164cbb
  • Case Links:
    none
  • Regression:
    No

Description

The following stack trace is spamming my agent.log.startup

2011-12-08 10:12:57,081 ERROR [Thread-3] [SystemErr] java.lang.NoSuchMethodError: java.lang.String.isEmpty()Z
2011-12-08 10:12:57,081 ERROR [Thread-3] [SystemErr]    at org.hyperic.hq.plugin.samba.SambaServerDetector.getServerProcessList(SambaServerDetector.java:89)
2011-12-08 10:12:57,081 ERROR [Thread-3] [SystemErr]    at org.hyperic.hq.plugin.samba.SambaServerDetector.getServerResources(SambaServerDetector.java:64)
2011-12-08 10:12:57,082 ERROR [Thread-3] [SystemErr]    at org.hyperic.hq.autoinventory.scanimpl.NullScan.scan(NullScan.java:81)
2011-12-08 10:12:57,082 ERROR [Thread-3] [SystemErr]    at org.hyperic.hq.autoinventory.Scanner.start(Scanner.java:198)
2011-12-08 10:12:57,082 ERROR [Thread-3] [SystemErr]    at org.hyperic.hq.autoinventory.ScanManager.mainRunLoop(ScanManager.java:141)
2011-12-08 10:12:57,082 ERROR [Thread-3] [SystemErr]    at org.hyperic.hq.autoinventory.ScanManager.access$000(ScanManager.java:41)
2011-12-08 10:12:57,082 ERROR [Thread-3] [SystemErr]    at org.hyperic.hq.autoinventory.ScanManager$1.run(ScanManager.java:107)

This is caused by String.isEmpty() not being present in Java 1.5 see http://docs.oracle.com/javase/6/docs/api/java/lang/String.html#isEmpty()

Activity

yael twina (c) added a comment -

it works fine in Version 4.6.5.BUILD-SNAPSHOT-2011-12-31


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 16 weeks, 1 day ago