Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

frantic - error when watching "mv" commands

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.6
  • Fix Version/s: 4.6.5
  • Component/s: Deprecated: Frantic
  • Environment:
    linux environment.,4.6+Frantic patch
  • Case Links:
    none
  • HQ Fix Version:
    4.6.5
  • Regression:
    No

Description

configuration changes stop being sent to the server.

in agent.log.startup it looks like the "ChangeEventProcessor" was thrown:

2011-12-13 14:03:45,094 ERROR [ChangeEventProcessor] [SystemErr] Exception in thread "ChangeEventProcessor"
2011-12-13 14:03:45,094 ERROR [ChangeEventProcessor] [SystemErr] java.lang.NullPointerException
2011-12-13 14:03:45,094 ERROR [ChangeEventProcessor] [SystemErr] at org.hyperic.cm.filemonitor.FileMonitor.onChange(FileMonitor.java:236)
2011-12-13 14:03:45,094 ERROR [ChangeEventProcessor] [SystemErr] at org.hyperic.cm.filemonitor.ChangeEventProcessor.fireEvent(ChangeEventProcessor.java:589)
2011-12-13 14:03:45,094 ERROR [ChangeEventProcessor] [SystemErr] at org.hyperic.cm.filemonitor.ChangeEventProcessor.processCommit(ChangeEventProcessor.java:481)
2011-12-13 14:03:45,094 ERROR [ChangeEventProcessor] [SystemErr] at org.hyperic.cm.filemonitor.ChangeEventProcessor.processEvent(ChangeEventProcessor.java:433)
2011-12-13 14:03:45,095 ERROR [ChangeEventProcessor] [SystemErr] at org.hyperic.cm.filemonitor.ChangeEventProcessor.run(ChangeEventProcessor.java:193)
2011-12-13 14:03:45,095 ERROR [ChangeEventProcessor] [SystemErr] at java.lang.Thread.run(Unknown Source)

those are the relevant events seen on the same time from the server log:

2011-12-13 13:53:17,158 INFO [Watcher] [Watcher] Event Queued: dummy /etc/resolv.conf /etc/resolv.conf.dhclient-new
2011-12-13 13:53:32,573 INFO [Thread-3] [MapPersister] persisting map
2011-12-13 13:53:32,710 INFO [Thread-3] [MapPersister] map persisting completed
2011-12-13 13:58:32,710 INFO [Thread-3] [MapPersister] persisting map
2011-12-13 13:58:32,845 INFO [Thread-3] [MapPersister] map persisting completed
2011-12-13 14:00:49,158 INFO [Watcher] [Watcher] Event Queued: delete /opt/apache-tomcat-6.0.35/webapps/petclinic/WEB-INF/classes/jasper.jar
2011-12-13 14:00:58,913 INFO [ChangeEventProcessor] [ChangeEventProcessor] Event processed and fired: revId:5f40222909a58f22af2ac01f7d6febd6fcb67887 delete /
opt/apache-tomcat-6.0.35/webapps/petclinic/WEB-INF/classes/jasper.jar
2011-12-13 14:01:07,914 INFO [Watcher] [Watcher] Event Queued: delete /opt/apache-tomcat-6.0.35/conf/catalina.old.properties
2011-12-13 14:01:17,799 INFO [ChangeEventProcessor] [ChangeEventProcessor] Event processed and fired: revId:8b654ef1f3e20a81fbd2a7f7ece809755b3c8e8e delete /
opt/apache-tomcat-6.0.35/conf/catalina.old.properties
2011-12-13 14:01:18,541 INFO [Watcher] [Watcher] path and target didn't pass filter /opt/apache-tomcat-6.0.35/conf/catalina.properties.old
2011-12-13 14:01:18,541 INFO [Watcher] [Watcher] Event Queued: dummy /opt/apache-tomcat-6.0.35/conf/catalina.properties.old
2011-12-13 14:01:18,542 INFO [Watcher] [Watcher] path and target didn't pass filter /opt/apache-tomcat-6.0.35/conf/catalina.properties.old
2011-12-13 14:01:18,542 INFO [Watcher] [Watcher] Event Queued: dummy /opt/apache-tomcat-6.0.35/conf/catalina.properties.old
2011-12-13 14:03:32,845 INFO [Thread-3] [MapPersister] persisting map
2011-12-13 14:03:32,981 INFO [Thread-3] [MapPersister] map persisting completed
2011-12-13 14:03:36,535 INFO [Watcher] [Watcher] Event Queued: rename /opt/apache-tomcat-6.0.35/webapps/travel/WEB-INF/lib/xml-apis-1.0.b3.jar
2011-12-13 14:03:45,093 INFO [ChangeEventProcessor] [ChangeEventProcessor] Event processed and fired: revId:eae339ea016f95eecdd3c3acf413e434ebc2c8d0 rename /
opt/apache-tomcat-6.0.35/webapps/travel/WEB-INF/lib/xml-apis-1.0.b3.jar
2011-12-13 14:03:52,571 INFO [Watcher] [Watcher] Event Queued: rename /opt/apache-tomcat-6.0.35/webapps/travel/WEB-INF/web2.xml /opt/apache-tomcat-6.0.35/web
apps/travel/WEB-INF/web.xml

attached is the full agent log

Activity

Zvika Messing added a comment -

actually there are 2 issues here:

1) why was the thread thrown
2) frantic should be able to continue working after "ChangeEventProcessor" is thrown

Adar Margalit added a comment -

Please split the "Processor thread crashes" issue (#2) in a separate bug.

Zvika Messing added a comment -
Adar Margalit added a comment -

Seems the cause of the exception was a rename event being generated with either the old path or new path being null. I've added handling so that the exception will not occur.
I'm not sure why this happened, and I'm not able to recreate. Added logging to help diagnose if it can be recreated.

Zvika Messing added a comment -

after the new patch its easy to see that the problem reproduces with every "mv" command that is moving the files (and not rename).

examples:
mv fileRealm_tmp2.properties /root/Oracle/Middleware/user_projects/domains/base_domain1/config/fileRealm_tmp2.properties

results:
2011-12-20 17:22:58,770 ERROR [ChangeEventProcessor] [FileMonitor] FileMonitor onChange(EventMessage item) - Path is null for event: rename, old path: null, new path: /root/Oracle/Middleware/user_projects/domains/base_domain1/config/fileRealm_tmp2.properties

Adar Margalit added a comment -

Fixed in build 20120208

Zvika Messing added a comment -

no error is seen on hyperic 4.6.5 RC2 when doing mv commands.
still mv commands are not treated right - opened
https://jira.hyperic.com/browse/HHQ-5453


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 9 weeks ago