Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

unable to run New Auto Discovery

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.6.5
  • Fix Version/s: 4.6.5
  • Component/s: None
  • Environment:
    agent 4.7 run on Linux SUSE 11 with vSphere 5 server
    and
    agent 4.7 run on WIN2008 with vSphere 5 server
  • Case Links:
    none
  • Regression:
    Yes

Description

go to Platform Resource view
Tools Menu -> New Auto-Discovery
Error:
The page requested cannot be displayed due to some error. You can hide the stack trace.Return to the previous page, Dashboard, or Browse Resources. page.
Exception:
org.hyperic.hq.common.SystemException: java.lang.NullPointerException at org.hyperic.hq.bizapp.server.session.AIBossImpl.getServerSignatures(AIBossImpl.java:181) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:309) at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:183) at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:150) at org.springframework.aop.aspectj.MethodInvocationProceedingJoinPoint.proceed(MethodInvocationProceedingJoinPoint.java:80) at org.hyperic.hq.monitor.aop.aspects.PerformanceMonitor.monitorServiceMethod(PerformanceMonitor.java:84) at sun.reflect.GeneratedMethodAccessor154.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.springframework.aop.aspectj.AbstractAspectJAdvice.invokeAdviceMethodWithGivenArgs(AbstractAspectJAdvice.java:621) at org.springframework.aop.aspectj.AbstractAspectJAdvice.invokeAdviceMethod(AbstractAspectJAdvice.java:610) at org.springframework.aop.aspectj.AspectJAroundAdvice.invoke(AspectJAroundAdvice.java:65) at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172) at org.springframework.transaction.interceptor.TransactionInterceptor.invoke

Issue Links

Activity

Eyal Maderer added a comment -

Due to the problem that it takes the server a lot of time to start, some of the components are not getting initialized properly (time out exceptions). In this case AutoinventoryPluginManager is null.

tzirla rozental (c) added a comment -

works fine in Hyperic Version 4.6.5.BUILD-SNAPSHOT-2012-01-01


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 15 weeks, 5 days ago