Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

agent is not going up after AgentUpgradeManager restarts it

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.6.5
  • Fix Version/s: 4.6.5
  • Component/s: Agent / PDK
  • Environment:
    agent on Windows OS
  • Case Links:
    none
  • Regression:
    No

Description

AgentUpgradeManager send restart command to the agent but it looks like the agent get shutdown command and do not go up.

relevant log file:
2011-12-25 18:20:20,338 INFO [ScheduleThread] [ScheduleThread] Creating executor for plugin 'system' with a poolsize=1 queuesize=10000
2011-12-25 18:21:47,742 INFO [commandlistener-receive_file-0] [AgentCommandsService] Preparing to write 13362 bytes to ../../bundles/agent-4.7.0.BUILD-SNAPSHOT/tmp/hqagent-plugin-update.jar (type=2)
2011-12-25 18:21:47,742 INFO [commandlistener-receive_file-0] [AgentCommandsService] Writing to 'C:\Program Files\agent-4.7.0.BUILD-SNAPSHOT-EE\wrapper\sbin\..\..\bundles\agent-4.7.0.BUILD-SNAPSHOT\tmp\hqagent-plugin-update.jar'
2011-12-25 18:21:47,742 INFO [commandlistener-receive_file-0] [AgentCommandsService] Successfully wrote: C:\Program Files\agent-4.7.0.BUILD-SNAPSHOT-EE\wrapper\sbin\..\..\bundles\agent-4.7.0.BUILD-SNAPSHOT\tmp\hqagent-plugin-update.jar
2011-12-25 18:21:53,164 INFO [commandlistener-generic-0] [AgentUpgradeManager] restart requested
2011-12-25 18:21:53,164 INFO [commandlistener-generic-0] [CommandListener] Shut down executor service for CommandListener generic
2011-12-25 18:21:53,164 INFO [commandlistener-generic-0] [CommandListener] Shut down executor service for CommandListener agenting
2011-12-25 18:21:53,164 INFO [commandlistener-generic-0] [CommandListener] Shut down executor service for CommandListener agent:receive_file
2011-12-25 18:21:53,164 INFO [commandlistener-generic-0] [AgentCommandsServer] Agent commands shut down
2011-12-25 18:21:53,164 INFO [commandlistener-generic-0] [AutoinventoryCommandsServer] Autoinventory Commands Server shutting down
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [AutoinventoryCommandsServer] Autoinventory Commands Server shut down
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [CommandsServer] Commands Server shut down
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [ControlCommandsServer] Control Commands Server shut down
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [MeasurementCommandsServer] Measurement Commands Server shutting down
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [ScheduleThread] Shut down executor service for plugin 'system' with 0 queued collections
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [ScheduleThread] Shutdown metric verification task with 2 tasks
2011-12-25 18:21:53,664 INFO [SenderThread] [SenderThread] Measurement sender interrupted
2011-12-25 18:21:53,664 INFO [ScheduleThread] [ScheduleThread] Schedule thread shut down
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [MeasurementCommandsServer] Measurement Commands Server shut down
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [RtCommandsServer] Response Time Commands Server shutting down
2011-12-25 18:21:53,664 INFO [RtSenderThread] [RtSenderThread] Rt sender interrupted
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [RtCommandsServer] Response Time Commands Server shut down
2011-12-25 18:21:53,664 INFO [commandlistener-generic-0] [SSLConnectionListener] closing listener socket 0.0.0.0/0.0.0.0:21442011-12-25 18:21:53,711 INFO [commandlistener-generic-0] [FileMonitor] Entered FileMonitor.stop()
2011-12-25 18:21:53,711 INFO [Watcher] [Watcher] watch service closed, terminating.
2011-12-25 18:21:53,711 INFO [commandlistener-generic-0] [RunnableTrackThread] RunnableLogThread stopped
2011-12-25 18:21:53,711 INFO [AgentDaemonMain] [AgentDaemon] Agent shut down

Activity

Guy Segev added a comment -

Invoke the wrapper's restart() prior to agent sequence so as to ensure that the 'Wrapper-Restarter' will handle the JVM's
shutdown hook properly rather than treating it as a stop command.

yael twina (c) added a comment -

After new installation, the agent still shutdown and do not go up. (with exception)
the problem still not solved.

(later i will attach the wrraper log)

relevant log file:
2011-12-28 12:00:57,753 INFO [commandlistener-generic-0] [AgentUpgradeManager] restart requested
2011-12-28 12:00:57,754 INFO [commandlistener-generic-0] [CommandListener] Shut down executor service for CommandListener generic
2011-12-28 12:00:57,754 INFO [commandlistener-generic-0] [CommandListener] Shut down executor service for CommandListener agent:ping
2011-12-28 12:00:57,754 INFO [commandlistener-generic-0] [CommandListener] Shut down executor service for CommandListener agent:receive_file
2011-12-28 12:00:57,754 INFO [commandlistener-generic-0] [AgentCommandsServer] Agent commands shut down
2011-12-28 12:00:57,754 INFO [commandlistener-generic-0] [CommandsServer] Commands Server shut down
2011-12-28 12:00:57,754 INFO [commandlistener-generic-0] [RtCommandsServer] Response Time Commands Server shutting down
2011-12-28 12:00:57,755 INFO [RtSenderThread] [RtSenderThread] Rt sender interrupted
2011-12-28 12:00:57,755 INFO [commandlistener-generic-0] [RtCommandsServer] Response Time Commands Server shut down
2011-12-28 12:00:57,755 INFO [commandlistener-generic-0] [AutoinventoryCommandsServer] Autoinventory Commands Server shutting down
2011-12-28 12:00:57,755 INFO [commandlistener-generic-0] [AutoinventoryCommandsServer] Autoinventory Commands Server shut down
2011-12-28 12:00:57,755 INFO [commandlistener-generic-0] [MeasurementCommandsServer] Measurement Commands Server shutting down
2011-12-28 12:00:57,757 INFO [commandlistener-generic-0] [ScheduleThread] Shutdown metric verification task with 2 tasks
2011-12-28 12:00:57,758 WARN [commandlistener-generic-0] [MeasurementCommandsServer] shutdown interrupted
2011-12-28 12:00:57,758 INFO [commandlistener-generic-0] [MeasurementCommandsServer] Measurement Commands Server shut down
2011-12-28 12:00:57,758 INFO [commandlistener-generic-0] [ControlCommandsServer] Control Commands Server shut down
2011-12-28 12:00:57,758 INFO [SenderThread] [SenderThread] Measurement sender interrupted
2011-12-28 12:00:57,762 INFO [Thread-3] [SSLConnectionListener] closing listener socket 0.0.0.0/0.0.0.0:2144
2011-12-28 12:00:57,757 INFO [ScheduleThread] [ScheduleThread] Schedule thread shut down
2011-12-28 12:00:57,758 INFO [commandlistener-generic-0] [SSLConnectionListener] closing listener socket 0.0.0.0/0.0.0.0:2144
2011-12-28 12:00:57,762 ERROR [commandlistener-generic-0] [CommandDispatcher] Error while processing request
java.lang.NullPointerException
at org.hyperic.hq.bizapp.agent.server.SSLConnectionListener.cleanup(SSLConnectionListener.java:248)
at org.hyperic.hq.agent.server.CommandListener.cleanup(CommandListener.java:135)
at org.hyperic.hq.agent.server.AgentDaemon.cleanup(AgentDaemon.java:347)
at org.hyperic.hq.agent.server.AgentDaemon.access$100(AgentDaemon.java:78)
at org.hyperic.hq.agent.server.AgentDaemon$RunnableAgent.shutdown(AgentDaemon.java:993)
at org.hyperic.hq.agent.AgentUpgradeManager.restartJVM(AgentUpgradeManager.java:69)
at org.hyperic.hq.agent.server.AgentCommandsService.restart(AgentCommandsService.java:299)
at org.hyperic.hq.agent.server.AgentCommandsServer.dispatchCommand(AgentCommandsServer.java:97)
at org.hyperic.hq.agent.server.CommandDispatcher.processRequest(CommandDispatcher.java:112)
at org.hyperic.hq.agent.server.CommandListener.handleConn(CommandListener.java:216)
at org.hyperic.hq.agent.server.CommandListener.access$100(CommandListener.java:57)
at org.hyperic.hq.agent.server.CommandListener$AgentDispatchTask.run(CommandListener.java:200)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)
2011-12-28 12:00:57,763 WARN [commandlistener-generic-0] [CommandListener] Error invoking method
org.hyperic.hq.agent.AgentRemoteException: java.lang.NullPointerException
at org.hyperic.hq.agent.server.CommandDispatcher.processRequest(CommandDispatcher.java:119)
at org.hyperic.hq.agent.server.CommandListener.handleConn(CommandListener.java:216)
at org.hyperic.hq.agent.server.CommandListener.access$100(CommandListener.java:57)
at org.hyperic.hq.agent.server.CommandListener$AgentDispatchTask.run(CommandListener.java:200)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.NullPointerException
at org.hyperic.hq.bizapp.agent.server.SSLConnectionListener.cleanup(SSLConnectionListener.java:248)
at org.hyperic.hq.agent.server.CommandListener.cleanup(CommandListener.java:135)
at org.hyperic.hq.agent.server.AgentDaemon.cleanup(AgentDaemon.java:347)
at org.hyperic.hq.agent.server.AgentDaemon.access$100(AgentDaemon.java:78)
at org.hyperic.hq.agent.server.AgentDaemon$RunnableAgent.shutdown(AgentDaemon.java:993)
at org.hyperic.hq.agent.AgentUpgradeManager.restartJVM(AgentUpgradeManager.java:69)
at org.hyperic.hq.agent.server.AgentCommandsService.restart(AgentCommandsService.java:299)
at org.hyperic.hq.agent.server.AgentCommandsServer.dispatchCommand(AgentCommandsServer.java:97)
at org.hyperic.hq.agent.server.CommandDispatcher.processRequest(CommandDispatcher.java:112)
... 6 more
2011-12-28 12:00:57,763 INFO [AgentDaemonMain] [FileMonitor] Entered FileMonitor.stop()
2011-12-28 12:00:57,765 INFO [Watcher] [Watcher] watch service closed, terminating.
2011-12-28 12:00:57,766 INFO [AgentDaemonMain] [RunnableTrackThread] RunnableLogThread stopped
2011-12-28 12:00:57,770 INFO [AgentDaemonMain] [AgentDaemon] Agent shut down

Guy Segev added a comment -

Was reopened on the wrong build

yael twina (c) added a comment -

the AgentUpgrade run with no problem.

yael twina (c) added a comment -

Works fine in Hyperic Version 4.6.5.BUILD-SNAPSHOT-2011-12-28


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 15 weeks, 6 days ago