Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

The Postgres DB server still running after shutting down Hyperic server until to stop manually

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 4.6.5
  • Fix Version/s: 4.6.5
  • Component/s: Deprecated: Server
  • Environment:
    Linux
  • Case Links:
    none
  • HQ Fix Version:
    4.6.5
  • Regression:
    Yes

Description

The Postgres DB server still running after shutting down Hyperic server until to stop manually.
steps to reproduce:
shutdown Hyperic server.
actual result:
check if Postgres server is runing
expected result:
the Postgres server should to stop.

Activity

Guy Segev added a comment -

Root cause:

Due to race condition between two wrapper invoked HqServer.main threads, the

main()
would exit (JVM process exits) prior to the
stopBuiltinDb()
residing in the
HQServer.stop()
being invoked.

Fix:

Moved the latter to a JVM shutdown hook

Show
Guy Segev added a comment -

Root cause:

Due to race condition between two wrapper invoked HqServer.main threads, the
main()
would exit (JVM process exits) prior to the
stopBuiltinDb()
residing in the
HQServer.stop()
being invoked.

Fix:

Moved the latter to a JVM shutdown hook
rivka pints (c) added a comment -

verified in Version 4.6.5.BUILD-SNAPSHOT-2012-01-18
I deleted exist server and re-install new server without to kill postgres server - installation is succeeded


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 13 weeks, 3 days ago