Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Error when starting agent with older jvm causes it to crash, due to unknown encryption provider

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: None
  • Fix Version/s: 4.6.5
  • Component/s: None
  • Case Links:
    none
  • Regression:
    No

Description

Agent cannot startup with an older jvm. I am using 1.6_12. This would affect all agent upgrades.

2012-01-13 21:08:57,508 INFO [AgentDaemonMain] [AgentDaemon@966] Agent shut down
2012-01-13 21:08:57,508 ERROR [AgentDaemonMain] [AgentDaemon@1022] Agent startup error:
org.hyperic.hq.agent.server.AgentStartException: Error running agent: Cannot support TLS_DHE_RSA_WITH_AES_256_CBC_SHA with currently installed providers
at org.hyperic.hq.agent.server.AgentDaemon.start(AgentDaemon.java:932)
at org.hyperic.hq.agent.server.AgentDaemon$RunnableAgent.run(AgentDaemon.java:1019)
at java.lang.Thread.run(Thread.java:619)

Activity

Hide
Scott Feldstein added a comment -

to test, try to start the agent with an older 1.6 or 1.5 jvm.

Show
Scott Feldstein added a comment - to test, try to start the agent with an older 1.6 or 1.5 jvm.
Hide
Greg Turnquist added a comment -

There is no logging doing on when a cipher is removed from the list.

Show
Greg Turnquist added a comment - There is no logging doing on when a cipher is removed from the list.
Hide
Greg Turnquist added a comment -

Added log statements. Installed and confirmed using a fictitious cipher name that it logged in the agent's log file that it was being dropped.

Show
Greg Turnquist added a comment - Added log statements. Installed and confirmed using a fictitious cipher name that it logged in the agent's log file that it was being dropped.

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 14 weeks ago